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About This Book

This book provides information on Studio. It contains the following chapters and appendices:

• Introduction to Studio

• Creating Class Definitions

• Adding Properties to a Class

• Adding Methods to a Class

• Adding Class Parameters to a Class

• Adding Relationships to a Class

• Adding Queries to a Class

• Adding Indices to a Class

• Adding Projections to a Class

• Adding XData Blocks to a Class

• Adding SQL Triggers and Foreign Keys

• Adding Storage Definitions to a Class

• Working with CSP Files

• Working with Routines

• Using the Studio Debugger

• Using Studio Templates

• Studio Menu Reference

• Setting Studio Options

• Frequently Asked Questions About Studio

• And a more detailed Table of Contents.

For information on class definitions, see Defining and Using Classes. Also see the Class Definition Reference.
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1
Introduction to Studio

Studio offers features that help you develop applications rapidly, in a single, integrated environment including:

• An editor in which to create

– Classes, including persistent, database classes and Web service classes

– Routines using ObjectScript

• Integrated syntax coloring and syntax checking for ObjectScript, Java, SQL, JavaScript, HTML, and XML.

• Support for teams of developers working with a common repository of application source code.

• A graphical source code debugger.

• The ability to organize application source code into projects.

Studio is a client application that runs on Windows-based operating systems. It can connect to any InterSystems server
(compatible with the current version of Studio) regardless of what platform and operating system that server is using, and
supports SSL/TLS-protected connections.

Note: A Studio client must be running either the same version or a higher version of the InterSystems product that the
InterSystems server is running.

1.1 Overview of the Studio Window
The main components of the Studio user interface are shown below:
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Figure 1–1: Studio Components

1. Editor window: Class Editor for editing class definitions, Routine Editor for editing routines and include files, and
CSP Editor for editing CSP definition text. Using CSP files with InterSystems IRIS is not recommended.

2. Class Browser window: for viewing existing classes.

3. Workspace window: three tabs let you display the contents of the current project, all open windows, or the content of
the current namespace.

4. Class Inspector window: for viewing and modifying keywords in a class definition.

5. Watch window: displays variables.

6. Title Bar: displays ConnectionName/Namespace@UserName - ProjectName.prj – Studio – ActiveDocument. If the
active document is maximized, the name shows in square brackets.

In addition to the windows displayed above, Studio contains wizards and templates for assisting with common tasks. These
include:

• Find in Files window: displays a search window.

• Output window: displays output from the InterSystems server (such as messages generated during class compilation).

• Code Snippets window: for viewing and dragging user-created code snippets.

• New Class wizard: defines a new class.

• Class member wizards that add members to class definitions for: properties, indexes, relationships, methods, parameters,
SQL triggers, queries, projections, storage, foreign keys, and XData blocks.

• Wizards that create classes from other technologies; from: Java classes and jar files, SML schema, SOAP client classes,
that provide access to COM objects, and DLL assembly files from .NET.

• HTML templates that add: colors, tables, tags, and scripts.
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• CSP Form wizard: creates an HTML form bound to an object in a CSP page. Using CSP files with InterSystems IRIS
is not recommended.

1.1.1 Running Studio from the Command Line

You can run Studio from the system's command line using the command Cstudio.exe (in the install-dir\bin directory). The
command and its parameters are case-sensitive.

DescriptionParameter

Help info?

Connect to the server named ServerName./Servername=ServerName

Connect to the server at  ip address[port]./Server=cn_iptcp:127.0.0.1[51773]::

Connect to the User namespace.You must also
define a server.

/Namespace=User

Open project MyProject.You must also define a
server and a namespace.

/Project=MyProject

Load routine test.int.cn_iptcp is a case sensitive
protocol identifier.

cn_iptcp://127.0.0.1:51773/User/test.int

Open listed documents and set cursor in specified
position.You must also define a server and a
namespace.

/files="tag+1^myroutine.int",User.Class1.cls

Attach to process.You must also define a server
and a namespace.

/pid=123

Connect without connection definition in registry
using ip address[port]:USER:username:password

/fastconnect=127.0.0.1[51773]:USER:_SYSTEM:SYS

1.2 Projects
Studio uses projects to organize application source code.

A project is a set of class definitions, routines, and include files. For example, you might create a Studio project to group
all classes for a single application.

You are always in a project, either one that you created or the default project that is created when you first open Studio.
The default project is called Default_yourusername (a prefix of Default_ followed by your username).

All files in a single project must be in the same namespace (and on the same InterSystems server). Each class or routine
can be associated with any number of projects. Each namespace can contain any number of projects.

The project stores information such as the class hierarchy in a given InterSystems namespace, used when you edit classes.
The project also stores debugging information (such as how to start the application you want to debug).
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1.3 Class Definitions
A class definition defines a class. A class definition consists of class members (such as properties and methods) and other
items, called keywords, each with associated values, that specify details of the class behavior.

Class definitions reside in a database where they are stored in the class dictionary. A class definition can be compiled, a
process which creates executable code that can create object instances based on the class definition. The source code for
the executable code created for a class consists of one or more routines. These generated routines can also be viewed in
Studio.

A class definition can be projected for use by other technologies. In the case of SQL, this projection is automatic. In the
case of Java, there is an additional compilation step in which a Java class is generated that corresponds to the class definition.
For details, see the chapter “Adding Class Projections.”

Within Studio, class definitions can be displayed and edited in a Class Editor window. Class definitions can also be viewed
in the Class Inspector window as keywords and their corresponding values in tables.

1.4 CSP Files
Using CSP files with InterSystems IRIS is not recommended.

In other InterSystems products, a CSP (Web Server Page) file is an HTML or XML text file containing CSP markup language.
The CSP engine processes a CSP file and generates from it an InterSystems class which is then used to respond to HTTP
events and provide Web content.

If you prefer a more programmatic approach to Web development, you can also use Studio to create and edit CSP classes
in the same way as you would work with any other class definitions.

Studio displays CSP files in a CSP Editor window. This editor provides syntax coloring of HTML and XML as well as
many of the scripting languages that may be contained in a CSP file.

The CSP Editor provides commands for performing common CSP and HTML editing tasks such as inserting CSP markup
tags. Studio also lets you view the results of a CSP file by selecting View > Web Page.

1.5 Routine Editor
Using the Routine Editor, you can directly create and edit the source for specific routines in a syntax-coloring editor. You
also use the Routine Editor to edit include files.

1.6 Multiple User Support
Studio is an object-based, client/server application. The source files—class definitions, routines, and include files—that
you can create and edit with Studio are stored in an InterSystems server and are represented as objects.

When you save a source file from Studio, it is saved in the InterSystems server you are connected to. If a source file is
modified on the server while you are viewing it in Studio, you are notified and asked if you want to load the newer version.
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Studio automatically detects when multiple users view the same source components simultaneously and manages access
concurrency. If you attempt to open a file that is being edited by another user, you are notified and asked if you want to
open the file in read-only mode.

1.7 Importing and Exporting Documents Locally
Normally any documents you work with in Studio (such as class definitions or routines) are stored in an InterSystems
database (which may be on a remote machine). You can import from and export to local files using Tools > Export and
Tools > Import.

Class definitions and routines are stored in local files as XML documents.

1.8 Debugging
Studio includes a source-level, GUI debugger. The debugger attaches (or starts up and attaches to) a target process running
on the same InterSystems server that Studio is connected to. The debugger controls this target process remotely and allows
you to watch variables, step through code, and set breakpoints.

You typically must have a project open in order to use the debugger; the project contains the information needed to start
the debug target (name of a routine, method, or client application). In addition, the project stores a list of breakpoints that
were set in a prior debugging session.

You can attach and break into a running process without having a project open. In this case Studio does not remember
breakpoint settings from previous sessions. See more about debugging in the chapter “Using the Studio Debugger.”

1.8.1 Debugging Object-Based Applications

At this time, Studio only allows source-level debugging of INT (ObjectScript routine). To step through, or set breakpoints
within classes, open the corresponding INT and use the debugging commands in it.

To make sure that the generated source code for a class is available:

1. Select Tools > Options.

2. Navigate to Compiler > Flags & Optimization in the left-hand pane.

3. Select the Keep generated source code check box.

1.9 Security
InterSystems security features control the use of Studio, the ability of Studio to connect to any InterSystems server, and
support for SSL/TLS-protected connections. When you start Studio, it presents a login screen; to use Studio, you must log
in as a user who holds the following privileges:

• %Development:Use - Use permission on the %Development resource grants access to various development-related
resources.

• %Service_Object:Use - Use permission on the %Service_Object resource grants access to the %Service_Bind-
ings service, which controls access to Studio.
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Also, you can connect to a namespace only if you have Read or Write permission for its default database.

The way in which a user is granted these various privileges depends on the instance’s security level, as described in the
following list.

• For an instance with minimal security, all users, including UnknownUser, have all privileges and access to all names-
paces. When presented with the Studio login screen, either leave the Username and Password fields blank or enter
“_SYSTEM”  and “SYS”  as the username-password pair.

• For an instance with normal security, you must be explicitly granted the specified privileges. This is established by
being assigned to a role or roles that holds these privileges.

• For an instance with locked-down security, the service that governs access to Studio (%Service_Bindings) is disabled
by default. By default, no user has access to Studio.

To change Studio authentication settings:

1. Use the InterSystems IRIS launcher to open the Management Portal.

2. Select System Administration > Security > Services.

3. Click Go in the View or edit service definitions section.

4. Click %Service_Bindings.

5. Select or clear the check boxes under Allowed Authentication Methods.

Note: Studio access may also be affected by any changes to default settings that have occurred since installation.

1.10 Source Control Hooks
Studio includes a mechanism for implementing custom hooks—code that is executed on the InterSystems server whenever
a document is loaded or saved. Typically these hooks are used to implement a connection to a source or revision control
system.

To define source control hooks, create a subclass of the %Studio.SourceControl.Base class and implement the callback
methods that you want. You can specify which Source Control class Studio should use from the Source Control Settings

page of the Management Portal. (Navigate to System Administration > Configuration > Additional Settings > Source Control.)

Refer to the %Studio.SourceControl.Base class and Integrating InterSystems IRIS with Source Control Systems for more
details.
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2
Creating Class Definitions

The Studio lets you create and edit class definitions. A class definition specifies the contents of a particular class including
its members (such as methods and properties) and characteristics (such as superclasses).

With Studio you can work with class definitions with several tools:

• Wizards to quickly create classes and class members

• Class Inspector to view and edit class characteristics in a table

• Class Editor to directly edit the class definition. The Class Editor is a full-featured text editor that provides syntax
coloring, syntax checking, and code completion drop-down menus of available options.

You can use all of these techniques interchangeably; Studio automatically ensures that all of these representations are
synchronized.

This chapter discusses general aspects of creating class definitions. Most of the following chapters in this book describe
how to create class members, such as properties, methods, parameters, and so forth.

2.1 Creating New Class Definitions
You can create a new class definition in Studio by using the New Class wizard.

Note: You must have an open project before you can work with class definitions in Studio. When working with class
definitions, Studio performs numerous interactions with the InterSystems IRIS server (such as for providing lists
of classes, class compiling, etc.). Internally, Studio uses projects to manage the details of this server interaction.

2.1.1 New Class Wizard

To open the New Class wizard, select File > New > General and select Class Definition.

The New Class wizard prompts you for information. Select Finish at any time (in this case, default values are provided for
any information you have not specified).

2.1.1.1 Name and Description Page

The New Class wizard prompts you for the following information (with the exception of class and package name, you can
later modify any of these values):
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Package Name

Package to which the new class belongs. You can select an existing package name or enter a new name. If you
enter a new name, the new package is automatically created when you save your class definition. The only punc-
tuation marks that property names can contain are a dot (.) and a leading percent sign (%).

For more information on packages, see the chapter “Package Options”  in Defining and Using Classes.

Class Name

Name of your new class. This must be a valid class name and must not conflict with the name of a previously
defined class. Note that you cannot change this class name later.

See the section “Classes”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide for
Server-Side Programming.

Description

(optional) Description of the new class. This description is used when the class' documentation is displayed in the
online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

2.1.1.2 Class Type Page

The New Class wizard asks you what type of class you would like to create. You can either extend (inherit from) a previously
defined class or create a new class by selecting one of the following options:

Persistent

Create a definition for a persistent class. Persistent objects can be stored in the database.

Serial

Create a definition for a serial class. Serial objects can be embedded in persistent objects to create complex data
types such as addresses.

Registered

Create a definition for a registered class. Registered objects are not stored in the database.

Abstract

Create a definition for an abstract class with no superclass.

Datatype

Create a definition for a data type class. A data type class is used to create user-defined data types.

CSP (used to process HTTP events)

Create a definition for a %CSP.Page class. A CSP class is used to create a CSP event handling class. This is a
programmatic way to create CSP Pages or to respond to HTTP events (for example, to create an XML server).
Using CSP files with InterSystems IRIS is not recommended.

Extends

Extend an existing class: check Extends and enter (or choose from a list) the name of an existing superclass.
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2.1.1.3 Data Type Class Characteristics Page

If you are creating a new data type class, the New Class wizard prompts for certain items particular to data type classes.
These include:

Client Data Type

The data type used by clients to represent this data enter a client application.

ODBC Data Type

The data type used by ODBC or JDBC to represent this data type. Choose a type that corresponds to how you
want this data type to appear to ODBC/JDBC based applications.

SQL Category

The SQL Category used by the InterSystems SQL Engine when it performs logical operations on this data type.

2.1.1.4 Persistent, Serial, Registered Class Characteristics Page

If you are creating a new persistent, serial, or registered class, the New Class wizard prompts for certain items particular
to persistent or serial classes. These include:

Owner

(optional) For a persistent class, enter the SQL username to be the owner of the new class. This username controls
privileges when this class is used via SQL. If this field is left blank, then the default owner, _system, is used.

SQL Table Name

(optional) For a persistent class, enter a name to be used for the SQL table that corresponds to this class. If this
field is left blank, then the SQL table name is identical to the class name. If the class name is not a valid SQL
identifier, you must enter an SQL table name here.

XML Enabled

(optional) If selected, the class is XML-enabled; that is, it has the ability to project itself as an XML document. It
can also be used in Web Service methods. This is equivalent to adding the %XML.Adaptor class to the class'
superclass list.

For more information see Using XML Tools as well as Creating Web Services and Web Clients.

Zen DataModel

This feature is not supported in InterSystems IRIS.

Data Population

(optional) If you select this option, your new class supports automatic data population. This is equivalent to adding
the %Library.Populate class to the class' superclass list.

Automatic data population allows you to easily create random data with which you can test the operation of your
class. To populate a class, compile it and then execute the class' Populate method (inherited from the
%Library.Populate class). For example, using the Terminal:

 Do ##class(MyApp.Person).Populate(100)

For more information see the chapter “InterSystems IRIS Data Population Utility”  in Defining and Using Classes.
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2.1.1.5 CSP Class Characteristics Page

If you are creating a new CSP class, the New Class wizard prompts for the following value:

Content Type

Specifies what the content type served by this CSP class is. The available options are HTML or XML. This option
is used to set the value of the CONTENTTYPE parameter of the new class to text/html or text/xml respectively.
You can later change this to whatever value you want.

Using CSP files with InterSystems IRIS is not recommended.

2.1.2 Results of Running the New Class Wizard

After running the New Class wizard, Studio displays a new Class Editor window. The Class Editor window contains your
new class definition. For example:

/// This is a Person class
class MyApp.Person extends %Persistent 
{
}

You can save this class definition in the InterSystems IRIS database, add class members such as properties or methods, or
edit the class definition using the Class Inspector.

2.2 Opening Class Definitions
You can open a previously saved class definition and display it in a Class Editor window by selecting the class in the Project
tab of the Workspace window and double-clicking it with the mouse.

If the class definition you want to open is not part of the current project, first add it to the current project using Project >

Add Class.

If the class definition you want to open is currently being edited by someone else, you are asked if you want to open the
class definition for read-only access.

2.3 Editing Class Definitions
You may modify any of the characteristics of a newly created or previously existing class definition (with the exception
of the class or package name). You can do this in two ways:

• Using the Class Inspector to change the value of a class or class member keyword.

• Changing a value in the class definition using the Class Editor.

For a list of class keywords and their meanings, see Defining and Using Classes. For details on class definitions, see the
Class Definition Language reference.
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2.4 Saving and Deleting Class Definitions
If you have modified a class definition, save it to the InterSystems IRIS database in either of the following ways:

• Use File > Save to save the contents of the current window.

• Use Save Project to save all modified class definitions in the current project.

To delete a class definition, in the Workspace window, select a class and select Edit > Delete class classname. The class
and all of its generated files are deleted.

2.5 Compiling Class Definitions
You can compile class definitions from Studio by:

• Using Build > Compile or the Compile icon, . This saves all modified class definitions and compiles the current class
definition (the one displayed in the active editor window).

• Using Build > Rebuild All or the Rebuild All icon, . This saves all open, modified class definitions and compiles all
classes in the current project.

Note: You can control how classes are compiled using options on Tools > Options dialog, Compiler tab.

2.5.1 Incremental Compilation

Studio can do incremental compilation of classes. The feature is enabled with the Skip Related Up-to-date Classes option.
To find this option, open the Tools > Options dialog, Compiler, Flags & Optimization tab.

When enabled, if changes have been made to source code in one or more methods, only those methods are compiled with
Build > Compile. (Use Build > Rebuild All to override.) Any changes to the class interface (properties, method signatures,
etc.) or storage definition cause a full compilation.

Incremental compilation is typically much faster than a full compilation and speeds up the process of making incremental
changes to methods (application logic) during development.

Incremental compilation works as follows:

1. The Class Compiler finds all methods whose implementation has changed, places their runtime code into a new routine,
such as MyApp.MyClass.5.INT, and compiles this routine.

2. The Class Compiler then modifies the runtime class descriptor for the class to use the new implementations of the
compiled methods. When an application invokes one of these methods, the new code is dispatched to and executed.

3. The rest of the class definition (compiled meta-information, storage information for persistent classes, runtime SQL
information) is left unchanged. Note that the previous implementation of the modified methods remains in the runtime
code, but is not executed.

When a full (non-incremental) compilation is performed, all of the extra routines containing incrementally compiled
methods are removed. Perform a full compilation on all classes before deploying an application to avoid having extra routines.
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2.6 Renaming Class Definitions
Once you have created a class definition you cannot change its name. You can perform the equivalent of this operation by
creating a copy of the class with a new name as follows:

1. Select Tools > Copy Class.

2. Select the class you want to rename in the From field.

3. Enter the new class name in the To field.

4. Select any of the three options: Add new class to project, Replace instances of the class name,
or Copy Storage Definition.

5. Select OK.

6. You have a new Class Editor window containing a copy of the original class definition. Using the Class Editor, you
can make any additional changes you desire. You can save this new class definition when you like.

7. You can, if you want, delete the old class definition.

2.7 Class Inspector
The Class Inspector displays the current class definition in an editable table. The main components of the Class Inspector
are described below:

Figure 2–1: Class Inspector
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1. Member Selector: Controls which set of keywords are displayed. You can choose to view either the Class-wide keywords
or the keywords for a specific class member (such as properties or methods).

2. Item Selector: Controls which specific class member is displayed (such as a particular property). The contents of the
list depend on the value of the Member Selector. Selecting (Summary) displays a list of all the members of the type
specified by the Member Selector.

3. Keywords: Lists the keywords for the current class or class member selected by the Member and Item Selectors.
Highlighting a keyword displays its description and allows editing select Edit at the right of the value or directly edit
the value). Keywords whose value was set explicitly (not inherited or set by default) are shown in bold.

4. Values: Lists the values of keywords displayed in the keyword list. Values modified since the last time the class defi-
nition has been saved are displayed in blue.

2.7.1 Starting the Class Inspector

To start the Class Inspector, select View > Inspector. The Class Inspector shares a pane with the Workspace; click on the
Inspector tab to access the Class Inspector.

2.7.2 Activating the Class Inspector

The Class Inspector displays current information when it is activated (it is gray when inactive). To activate the Class
Inspector:

1. Make sure that the current editor window contains a class definition (the Class Inspector does not work with Routines).

2. Select the Class Inspector

When the Class Inspector is activated, its background turns white and its contents are updated to reflect the current class
definition. If you modify any keyword values using the inspector, the corresponding Class Editor window becomes inactive
(turn gray). When you are finished with the inspector, select the original Class Editor window. It becomes active and displays
the result of the modifications you made using the Class Inspector.
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If you right-click in the Class Inspector, it displays a popup menu allowing you to perform operations such as adding new
class members.

2.8 Class Browser
Studio includes a class browsing utility that lets you view all available classes arranged by class hierarchy. Within each
class you can view class members such as properties and methods, including those inherited from superclasses. The Class
Browser displays class members in a table. By select a column title, you can sort the class members by that column.

1. Open the Class Browser with Tools > Class Browser.

2. Right-click an item in the Class Browser and select whether to add it to the project, open it in the Class Editor, or view
documentation.

2.9 Superclass Browser and Derived Class Browser
Studio includes two additional browsers, one for listing all superclasses and one for listing derived classes from the current
class definition.

2.9.1 Superclass Browser

Open the Superclass Browser using Class > Superclasses to display an alphabetical list of all superclasses of the current
class.

Select a class and then select a button to either add it to the current project, open it in the Class Editor, or view documentation.

2.9.2 Derived Class Browser

Open the Derived Class Browser using Class > Derived Classes to display a list, in alphabetical order, of all the classes
derived from the current class definition.

Select a class and then select a button to either add it to the current project, open it in the Class Editor, or view documentation.

2.10 Package Information
Within Studio, you can view and edit information about a specific class package using the Package Settings dialog.

To open Package Information, in the Workspace window, in the Project tab, right-click the package name and select
Package Information.
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Figure 2–2: Package Settings dialog

The Package Information window displays the following information:

Name of the package.Package Name

Description of the packageDescription

SQL Owner name of this package. This is used to provide
Schema-wide privileges to the SQL representation of the package.

Owner

Name of the SQL Schema used to represent the package
relationally.

SQL Name

Package name used for the generated projection of this package's
classes. For example, if this package contains a class named
bank.account, and you give it a client package name of
com.mycompany.bank. when the class is compiled, a Java projection
of this class is put into com.mycompany.bank.account.

Client Name

String that is used as a prefix for the routines generated from
classes in this package

Routine Prefix

String that is used as a prefix for the default global names used by
persistent classes in this package

Global Prefix

For more information on class packages, see the chapter “Packages”  in Defining and Using Classes.
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3
Adding Properties to a Class

This chapter describes how to add properties in a class definition.

The data, or state, of an object is stored in its properties. Every class definition may contain zero or more property definitions.

You can add a new property to a class in two ways:

• Adding the property to the class definition in the Class Editor.

• Using the New Property wizard

To add a property using the Class Editor, position the cursor on a blank line in the Class Editor and enter a property decla-
ration:

Class MyApp.Person Extends %Persistent 
{
Property Name As %String;
Property Title As %String;
}

Alternatively, copy an existing property declaration, paste it into a new location, and edit it.

For details on property definitions, see “Defining and Using Literal Properties”  and subsequent chapters in Defining and
Using Classes. Also see “Property Definitions”  in the Class Definition Reference.

3.1 New Property Wizard
To open the New Property wizard, select Class > Add > Property . Alternatively, right-click the Class Inspector and select
Add > New Property or, if only properties are displayed (Property heads the left column), right-click and select New

Property or select the New Property icon,  from the toolbar.

The New Property wizard prompts you for information. Select Finish at any time; default values are provided for any
information you have not specified.

3.1.1 Name and Description Page

The New Property wizard prompts you for the following information (you can later modify any of these values):
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Property Name

(required) Name of the new property. This name must be a valid property name and must not conflict with the
name of a previously defined property. The only punctuation marks that property names can contain are a dot (.)
and a leading percent sign (%).

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new property. This description is used when the class' documentation is displayed
in the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

3.1.2 Property Type Page

The New Property wizard asks you to select the property type: single-valued, a collection, a stream, or a relationship. You
can further refine each of these choices by specifying additional characteristics, such as data type.

Single Valued

A single-valued property is just that; it contains a single value. A single-valued property has a type associated
with it. This type is the name of an InterSystems IRIS class. If the class used as a type is a data type class, then
the property is a simple literal property; if it is a persistent class, then the property is a reference to an instance of
that class; if it is a serial class, then the property represents an embedded object.

You can enter a class name directly or choose from a list of available classes, including streams, using the Browse

button.

For a description of the basic data type classes provided with InterSystems IRIS, see the chapter “Data Types”
in Defining and Using Classes.

Collection

A collection property contains multiple values. There are two collection types, List (a simple, ordered list) and
Array (a simple dictionary with elements associated with key values). As with a single-valued property, a collection
property also has a data type. In this case, the data type specifies the type of the elements contained in the collection.

See “Working with Collections”  in Defining and Using Classes.

Relationship

A relationship property defines an association between two objects. For more details on relationships, see
“Defining and Using Relationships”  in Defining and Using Classes.

3.1.3 Property Characteristics Page

If you are adding a new property to a class definition for a persistent or serial object, the New Property wizard asks for
additional characteristics. These include:

Required

(optional) This is only relevant for persistent or serial classes. Specifies that this property is required (NOT NULL
in SQL terminology). For persistent or serial objects, a required property must be given a value or else any attempt
to save the object fails.
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Indexed

(optional) This is only relevant for persistent classes. Specifies that an index should be created based on this
property. This is equivalent to creating an index based on this field.

Unique

(optional) This is only relevant for persistent classes. Specifies that the value of this property must be unique in
the extent (set of all) objects of this class. This is equivalent to creating a unique index based on this field.

Calculated

(optional) A calculated property has no in-memory storage allocated for it when an object instance is created.
Instead, you must provide accessor (Get or Set) methods for the property. If you choose this option, the New
Property wizard can generate an empty Get accessor method for you.

SQL Field Name

(optional) In the case of a persistent class, this is the name that should be used for the SQL field that corresponds
to this property. By default (when this field is blank) the SQL field name is identical to the property name. Provide
an SQL field name if you want to use a different field name or if the property name is not a valid SQL identifier.

3.1.4 Data Type Parameters Page

Every property has a list of parameter values which is determined by the type of the property. The values of these parameters
control aspects of the property's behavior. Using the table displayed on the Parameters page of the New Property wizard,
you can specify the value of particular parameters.

For information on the common parameters, “Defining and Using Literal Properties”  in Defining and Using Classes.

3.1.5 Property Accessors Page

You can override the Set method (used to set the value of a property) and Get method (used to retrieve the value of a
property) for a property by selecting the corresponding override check box. Choosing one of these options creates an empty
Set or Get method which you have to fill in later. See “Using and Overriding Property Methods”  in Defining and Using
Classes.

3.1.6 Results of Running the New Property Wizard

After running the New Property wizard, the Class Editor is updated to include the new property definition. For example:

/// This is a Person class
Class MyApp.Person extends %Persistent
{
Property Name As %String;
}

You can use the Class Editor or the Class Inspector to make additional changes to this property.
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4
Adding Methods to a Class

This chapter discusses how to add and edit method definitions in a class definition.

You can add a new method to a class definition in two ways:

• Adding a method to the class definition using the Class Editor.

• Using the New Method wizard

To add a method using the Class Editor, position the cursor on a blank line in the Class Editor and enter a method declaration
such as:

Class MyApp.Person Extends %Persistent 
{
Method NewMethod() As %String
{
    Quit ""
}
}

Alternatively, you can do this by copying and pasting an existing method declaration and then editing it.

For details on method definitions, see “Defining and Calling Methods”  in Defining and Using Classes. Also see “Method
Definitions”  in the Class Definition Reference.

4.1 New Method Wizard
You can invoke the New Method wizard by selecting Class > Add > Method. Alternatively, right-click the Class Inspector

and select Add > New Method. You can also click the New Method button  from the toolbar.

The New Method wizard prompts you for information. Click Finish at any time (default values are provided for any infor-
mation you have not specified).

4.1.1 Name and Description Page

The New Method wizard prompts you for the following information (you can later modify any of these values):

Method Name

(required) Name of the new method. This name must be a valid method name and must not conflict with the name
of a previously defined method.
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See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new method. This description is used when the class' documentation is displayed in
the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

4.1.2 Method Signature Page

Every method has a signature that indicates its return type (if any) as well as its formal argument list (if any). For a method
signature you may specify the following:

Return Type

(optional) Indicates the type of the value returned by this method. This type is the name of an InterSystems IRIS
class. You can type this name in directly or choose from a list of available classes using the Browse button.

For example, a method that returns a true (1) or false (0) value would have a return type of %Boolean. Leave this
field empty if your new method has no return value.

Arguments

(optional) Indicates the names, types and default values of the method's formal arguments along with how data is
passed (by reference or by value). The arguments are displayed in order in a table. You can add a new item to the

argument list by clicking the Add button  located on the side of the table. This displays a popup dialog allowing
you to specify the name of the argument, its type, its optional default value, and whether it is passed by value or
by reference. Using the other buttons, you can remove and rearrange the order of items in the list.

4.1.3 Method Characteristics Page

You may specify additional characteristics for your method. These include:

Private

(optional) Indicates whether this method is public or private. Private methods can only be invoked from other
methods of the same class.

Final

(optional) Indicates whether this method is final. Final methods cannot be overridden by subclasses.

Class Method

(optional) Indicates that the new method is a class method (as opposed to an instance method). Class methods may
be invoked without having an object instance.

SQL Stored Procedure

(optional) Indicates that this method is accessible to an ODBC or JDBC client as a stored procedure. Only class
methods may be projected as SQL Stored Procedures.
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4.1.4 Implementation Page

If you want, you may enter the implementation (code) for the new method by typing lines of source code into the Class
Editor. You can also enter this source code after running the wizard.

4.1.5 Results of Running the New Method Wizard

After running the New Method wizard, the Class Editor is updated to include the new method definition. You can edit it
using either the Class Editor or the Class Inspector. For example:

/// This is a Person class
class MyApp.Person extends %Persistent
{
Method Print() As %Boolean
{
    Write "Hello"
    Quit 1
}
}

4.2 Overriding a Method
Note: The Refactor submenu is available only when Studio is connected to a Windows server. The Override menu item

is available in other platforms.

One of the powerful features of object-based development is that classes inherit methods from their superclasses. In some
cases, you may want to override, that is, provide a new implementation for, a method inherited from a superclass.

Class > Refactor > Override simplifies the process of overriding a class method by displaying a list of all the methods defined
by superclasses that can be overridden by the current class.

For example, in a persistent class, you may want to override the default implementation of the %OnValidateObject method
provided by the %RegisteredObject class in order to specify custom validation that occurs when an instance of your class
is saved.

To do this, follow these steps:

1. Open (or create) a persistent class definition in Studio.

2. Select Class > Refactor > Override and select the Methods tab. This displays a dialog window containing a list of
methods which you can override.

3. Select %OnValidateObject from the list and select OK button.

Your class definition now includes a definition for an %OnValidateObject method:

class MyApp.Person extends %Persistent 
{
// ...
Method %OnValidateObject() As %Status
{
}
}

At this point, you can use the Class Editor to add code to the body of the method.
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5
Adding Class Parameters to a Class

A class parameter defines a constant value for all objects of a given class. When you create a class definition (or at any
point before compilation), you can set the values for its class parameters. By default, the value of each parameter is the
null string; to set a parameter's value, you must explicitly provide a value for it. At compile-time, the value of the parameter
is established for all instances of a class. This value cannot be altered at runtime.

You can add a class parameter to a class definition in two ways:

• Adding a class parameter to the class definition using the Class Editor.

• Using the New Class Parameter wizard.

To add a parameter using the Class Editor, position the cursor on a blank line in the Class Editor and enter a class parameter
such as:

Parameter P1 = "x";

For details on parameter definitions, see “Defining and Referring to Class Parameters”  in Defining and Using Classes.
Also see “Parameter Definitions”  in the Class Definition Reference.

5.1 New Class Parameter Wizard
You can use the New Class Parameter Wizard to create a new class parameter. You can open the New Class Parameter
wizard by selecting Class > Add > Class Parameter . Alternatively, right-click the Class Inspector and select Add > New

Class Parameter. You can also click the New Class Parameter button  on the toolbar.

The New Class Parameter wizard prompts you for information. Select Finish at any time (default values are provided for
any information you have not specified).

The New Class Parameter wizard prompts you for the following information (you can later modify any of these values):

Name

(required) Name of the class parameter. This name must be a valid parameter name and must not conflict with the
name of a previously defined parameter.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.
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Description

(optional) Description of the new class parameter. This description is used when the class' documentation is displayed
in the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

Default

Default value for the class parameter. This will be the default value for this parameter for all instances of this
class.
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6
Adding Relationships to a Class

A relationship is a special type of property that defines how two or more object instances are associated with each other.
For example, a Company class that represents a company could have a one-to-many relationship with an Employee class
that represents an employee (that is, each company may have one or more employees while each employee is associated
with a specific company).

A relationship differs from a property in that every relationship is two-sided: for every relationship definition there is a
corresponding inverse relationship that defines the other side.

For more information on relationships, see the chapter “Relationships”  in Defining and Using Classes.

You can add a new relationship to a class definition in two ways:

• Adding a relationship to the class definition using the Class Editor.

• Using the New Property wizard

To add a relationship using the Class Editor, position the cursor on a blank line in the Class Editor and enter a relationship
declaration:

Class MyApp.Company Extends %Persistent 
{
Relationship TheEmployees As Employee [cardinality=many, inverse=TheCompany];
}

A relationship definition must specify values for both the cardinality and inverse keywords.

As this relationship has two sides, also enter the inverse relationship in the class definition of Employee:

Class MyApp.Employee Extends %Persistent 
{
Relationship TheCompany As Company [cardinality=one, inverse=TheEmployees];
}

If the two sides of the relationship do not correctly correspond to each other, there are errors when you try to compile.

6.1 New Property Wizard to Create a Relationship Property
You can use the New Property Wizard to create a new relationship property. To invoke this wizard, select Class > Add >

Property. Alternatively, right-click the Class Inspector and select Add > New Property. You can also click the New Property

button on the toolbar.

The New Property wizard prompts you for information. The procedure is identical to creating a new, non-relationship
property except that you specify Relationship on the property type.
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6.1.1 Name and Description Page

The New Property wizard prompts you for the following information (you can later modify any of these values):

Property Name

(required) Name of the relationship. This name must be a valid relationship (property) name and must not conflict
with the name of a previously defined relationship or property.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new relationship. This description is used when the class' documentation is displayed
in the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

6.1.2 Property Type Page

The New Property wizard asks you to choose from a variety of property types. Choose Relationship and enter the name
of the class on the inverse side of the relationship.

6.1.3 Relationship Characteristics Page

The New Property wizard asks for additional relationship characteristics. These include:

Cardinality

One: one other object

This relationship property refers to a single instance of the related object. The resulting property acts like a simple
reference field.

Many: many other objects

This relationship property refers to a one or more instances of the related object. The resulting property acts like
a collection of objects.

Parent: this object's parent

Identical to cardinality of one except that it is a dependent relationship and this property refers to the parent of
this object. When you create a parent-child relationship, you are not given the option to create an index because
children aren't stored independently but within the parent; you can see that by looking at the global structure. The
children are indexed automatically by creating an extra subscript.

Children: the object's children

Identical to cardinality of many except that this is a dependent relationship and this property refers to a collection
of child objects.

Inverse:
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This relationship property references objects of the following type

Select a class by clicking the Browse button or enter a new class name for the inverse side of the relationship.

The name of the corresponding property in the referenced class

Select a property from the class or enter a new property name for the inverse side of the relationship.

6.1.4 Additional Changes

Select any of the additional changes that you would like to implement:

Create a new class “<inverse class>”

This field is active only if the class name you specified on the previous page of the wizard does not exist. Select
this option to add the new class to the package. You must compile the new class before you can compile the class
that contains the relationship.

Create a new property “Parent”  in class “<inverse class>”

This field is active only if the property of the referenced class that you specified on the previous page of the wizard
does not exist. Select this option to add this new property to the class. You must compile the class with this new
property before you can compile the class that contains the relationship.

Modify property “Parent”  of class “<inverse class>”

This field is active only if the property of the referenced class already exists. Select this option to modify the ref-
erenced property to be a relationship with the property that you are defining.

Define an index for this relationship.

Select to define an index for this property. This is applicable only for One-To-Many relationships; it is disabled
for Parent-Child relationships

6.1.5 Results of Creating a New Relationship with the New Property Wizard

After creating a new relationship with the New Property wizard, the Class Editor is updated to include the new relationship
definition. For example:

/// This is an Employee class
class MyApp.Employee extends %Persistent
{

/// We have a one-to-many relationship with Company
Relationship Company As Company [cardinality=one, inverse=Employees];
}

If you want to make further modifications to this relationship, you can do this using either the Class Editor or the Class
Inspector.

Additionally, you can use the Modify Relationship wizard, which has the advantage of automatically determining the
changes required to the inverse of a relationship.

To open the Modify Relationship wizard:

1. Display the list of properties in the Class Inspector.

2. Right-click the desired relationship in the list of properties and select Add/Modify Relationship from the pop-up menu.
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7
Adding Queries to a Class

InterSystems IRIS class definitions may contain query definitions.

For an introduction, see “Defining and Using Class Queries”  in Defining and Using Classes. For details, see “Query
Definitions”  in the Class Definition Reference.

You can add a new query to a class definition in two ways:

• Edit the class definition using the Class Editor.

• Use the New Query wizard.

To add a query using the Class Editor, position the cursor on a blank line in the Class Editor and enter a query declaration
such as:

Class MyApp.Person Extends %Persistent
{
Property Name As %String;

/// This query provides a list of persons ordered by Name.
Query ByName(ByVal name As %String) As %SQLQuery(CONTAINID = 1)
{
    SELECT ID,Name FROM Person
    WHERE (Name %STARTSWITH :name)
    ORDER BY Name
}

}

Alternatively, you can copy and paste an existing query declaration and then edit it.

7.1 New Query Wizard
You can use the New Query wizard to add a new query to a class definition. You can open the New Query wizard by
selecting Class > Add > Query. Alternatively, right-click the Class Inspector and select Add > New Query. You can also click

the New Query button  in the toolbar.

Select Finish at any time; default values are provided for any information you have not specified.

7.1.1 Name, Implementation, and Description Page

The New Query wizard prompts you for the following information (you can later modify any of these values):
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Query Name

(required) Name of the new query. This name must be a valid query name and must not conflict with the name of
a previously defined query.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Implementation

(required) You must specify if this query is based on an SQL statement (which the wizard generates for you) or
on user-written code (in which case you have to provide the code for the query implementation).

Description

(optional) Description of the new query. This description is used when the class documentation is displayed in the
online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

7.1.2 Input Parameters Page

A query may take zero or more input parameters (arguments).

You can specify the names, types, and default values for these parameters. The arguments are displayed in order in a table.

You can add a new item to the argument list using the Add icon  located on the side of the table. This displays a popup

dialog allowing you to specify the name of the argument, its type, its optional default value. Using up, , and down arrows,

, you can rearrange the order of items in the list.

7.1.3 Columns Page

For an SQL-based query, you must specify the object properties (columns) that you want included in the result set (this is
the SELECT clause of the generated SQL query).

To add a column to the query, select an item from the left-hand list of available properties and move it to the right-hand
list using the > (Move To) button. You can also move the properties by double-clicking them.

7.1.4 Conditions Page

For an SQL-based query, you can specify conditions to restrict the result set (the SQL WHERE clause of the generated
SQL query).

You can build a set of conditions by selecting values from the set of combo boxes. The expression box can contain an
expression (such as a literal value) or a query argument (as an SQL host variable with a prepended : colon character).

7.1.5 Order By Page

For an SQL-based query, you can specify any columns you want to use to sort the result set (the SQL ORDER BY clause
of the generated SQL query).

7.1.6 Row Specification Page

For a user-written query, you must specify the names and types of the columns that are to be returned by the query.
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The wizard does not prompt for this information for SQL-based queries as the class compiler can determine it by examining
the SQL query.

7.1.7 Results of Running the New Query Wizard

After you run the New Query wizard, the Class Editor window is updated to include the new query definition. For example:

/// This is a Person class
class MyApp.Person extends %Persistent 
{

Query ByName(ByVal name As %String) As %SQLQuery(CONTAINID = 1)
{
    SELECT ID,Name FROM Person
    WHERE (Name %STARTSWITH :name)
    ORDER BY Name
}

}

If you want to make further modifications to this query you can do this using either the Class Editor or the Class Inspector.

If you specified a user-written query, the Class Editor contains both the new query definition as well as skeletons of the
query methods you are expected to implement. For example:

Class MyApp.Person Extends %Persistent 
{
// ...

ClassMethod MyQueryClose(
        ByRef qHandle As %Binary
        ) As %Status [ PlaceAfter = MyQueryExecute ]
{
    Quit $$$OK
}

ClassMethod MyQueryExecute(
        ByRef qHandle As %Binary,
        ByVal aaa As %Library.String
        ) As %Status
{
     Quit $$$OK
}

ClassMethod MyQueryFetch(
        ByRef qHandle As %Binary,
        ByRef Row As %List,
        ByRef AtEnd As %Integer = 0
        ) As %Status [ PlaceAfter = MyQueryExecute ]
{
    Quit $$$OK
}

Query MyQuery(
        ByVal aaa As %Library.String
        ) As %Query(ROWSPEC = "C1,C2")
{
}

}
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8
Adding Indices to a Class

This chapter discusses how to add and edit index definitions to a persistent class definition.

An index definition instructs the InterSystems IRIS class compiler to create an index for one or more properties. Indices
are typically used to make SQL queries more efficient. See “Defining and Building Indices”  in the SQL Optimization
Guide.

You can add an index to a class definition in two ways:

• Editing the class definition using the Class Editor.

• Using the New Index wizard

To add an index using the Class Editor, position the cursor on a blank line in the Class Editor and enter an index declaration:

Index NameIndex On Name;

Alternatively, copy and paste an existing index declaration and then edit it.

For details, see “ Index Definitions”  in the Class Definition Reference.

8.1 New Index Wizard
You can invoke the New Index wizard using the Class > Add > Index. Alternatively, right-click the Class Inspector and

select Add > New Index. You can also click the New Index button  from the toolbar.

The New Index wizard prompts you for information. If you click Finish before completing all of the wizard screens, default
values are set for any information you did not provide.

8.1.1 Name and Description Page

The New Index wizard prompts you for the following information (you can later modify any of these values):

Index Name

(required) Name of the new index. This name must be a valid index name and must not conflict with the name of
a previously defined index.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.
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Description

(optional) Description of the new index. This description is used when the class' documentation is displayed in
the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

8.1.2 Index Type Page

InterSystems IRIS supports the following types of indices.

Normal Index

A normal index is used for indexing on property values. You can further qualify a normal index by selecting one
of the following:

The set of properties associated with this index must have a combined value
that is unique in the extent of objects of this class.

Unique Index

The set of properties associated with this index are used to create the Object
ID value used to store instances of this class in the database.You cannot modify
the values of properties that are part of an IDKEY definition once an object has
been saved. IDKEY implies that the property or properties are unique (as with
a Unique Index).

IDKEY

The set of properties associated with this index is reported as the SQL Primary
Key for the SQL table projected for this class. This implies that the property or
properties are unique (as with a Unique Index).

SQL Primary
Key

Extent Index

An extent index is used to keep track of which objects belong to a specific class in a multiclass extent of objects.
It differs from a “normal index”  in that you cannot specify additional characteristics for it.

You can also select how the index is physically implemented in the database:

Standard Index

This index is a traditional cross-index on the specified property or properties.

Bitmap Index

A bitmap index uses a compressed representation of a set of object ID values that correspond to a given indexed
value. See Bitmap Indices in InterSystems SQL Optimization Guide for more information.

Bitslice Index

A bitslice index is a specialized form of index that enables very fast evaluation of certain expressions, such as
sums and range conditions. See Bitslice Indices in InterSystems SQL Optimization Guide for more information.

8.1.3 Index Properties Page

On the Index Properties page, you can enter a list of one or more properties on which the index is based. For each property
you can override the default collation function used to transform values stored in the index as well as any parameters for
the collation function.
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Important: There must not be a sequential pair of vertical bars (||) within the values of any property used by an IDKEY
index, unless that property is a valid reference to an instance of a persistent class. This restriction is imposed
by the way in which the InterSystems IRIS SQL mechanism works. The use of || in IDKey properties can
result in unpredictable behavior.

8.1.4 Index Data Page

On the Index Data page, elect to store a copy of the data for any properties in the index.

You cannot store copies of data values with a bitmap index.

8.1.5 Results of Running the New Index Wizard

After running the New Index wizard, the Class Editor is updated to include the new index definition. For example:

/// This is a Person class
class MyApp.Person extends %Persistent 
{

Property Name As %String;

Index NameIndex On Name;
}

You can edit the index definition with either the Class Editor or the Class Inspector.

8.2 Populating an Index
After you add an index definition to a class and compile, you can populate the index (place data into it) by using Rebuild

Indices, found in the Management Portal. For more information, see “Building Indices”  in the InterSystems SQL Optimization
Guide.

Studio does not automatically index existing data.
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9
Adding Projections to a Class

This chapter discusses how to add projection definitions in a class definition.

A projection definition instructs the InterSystems IRIS class compiler to perform specified operations when a class definition
is compiled or removed. A projection defines the name of a projection class (derived from the %Projection.AbstractProjection

class) that implements methods that are called when either of the following is true:

• The compilation of a class is complete.

• A class definition is removed either because it is being deleted or because the class is about to be recompiled.

A class can contain any number of projection definitions. The actions for all of them are invoked when the class is compiled
(the order in which they are invoked is not defined).

InterSystems IRIS includes predefined projection classes that generate client code that allows access to a class from Java,
MV, and so on.

Table 9–1: Projection Classes

DescriptionClass

Generates a Java client class to enable access to the class from Java.%Projection.Java

Registers this class as a routine that works with Log Monitor. Metadata
is written to Monitor.Application, Monitor.Alert, Monitor.Item and
Monitor.ItemGroup. A new persistent class is created called
Monitor.Sample.

%Projection.Monitor

Generates an MV class that enables access to the class from MV.%Projection.MV

Registers this class as a routine that works with Studio.%Projection.StudioDocument

Projects the XData 'menu' block to the menu table.%Studio.Extension.Projection

You can also create your own projection classes and use them from Studio as you would any built-in projection class.

You can add a new projection to a class definition in two ways:

• Editing the class definition using the Class Editor.

• Using the New Projection wizard

To add a projection using the Class Editor, position the cursor at a blank line and enter a projection declaration.

Alternatively, you can copy and paste an existing projection declaration and then edit it.
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For details, see “Projection Definitions”  in the Class Definition Reference.

9.1 New Projection Wizard
You can invoke the New Projection wizard by selecting Class > Add > Projection. Alternatively right-click in the Class
Inspector and select Add > New Projection.

The New Projection wizard displays pages prompting you for information about the new projection. You can click Finish

before completing all of the wizard pages; in this case, default values are provided for any information you have not spec-
ified.

9.1.1 Name and Description Page

The New Projection wizard prompts you for the following information (you can later modify any of these values):

Projection Name

(required) Name of the new projection. This name must be a valid projection name and must not conflict with the
name of a previously defined projection.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new projection.

9.1.2 Projection Type Page

The projection type determines what actions happen when your class definition is compiled or removed. You can select
what kind of projection you would like to define.

Projection Type

Name of a projection class whose methods are executed when a class definition is compiled or removed.

Projection Parameters

A set of name-value pairs that control the behavior of the projection class. The list of available parameter names
is determined by the selected projection class.

9.1.3 Results of Running the New Projection Wizard

When you finish running the New Projection wizard, the Class Editor window is updated to include the new projection
definition. For example:

/// This is a Person class
class MyApp.Person extends %Persistent 
{

Property Name As %String;

Projection JavaClient As %Projection.Java;
}

To edit this projection definition, use either the Class Editor or the Class Inspector.
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10
Adding XData Blocks to a Class

An XData block is a block of XML code that you can add to your class definition.

You can add an XData block to a class definition in two ways:

• Editing the class definition using the Class Editor.

• Using the XData wizard

To add an XData block using the Class Editor, position the cursor at a blank line and enter an XData declaration such as:

XData ProductionDefinition
    {
    <Production>
    <ActorPoolSize2/ActorPoolSize>
    </Production>
    } 

Alternatively, you can copy and paste an existing XData block and then edit it.

10.1 New XData Wizard
You can invoke the New XData wizard using the Class > Add > XData.

The New XData wizard displays a single page prompting you for a name for the XData block and a description. To end,
select Finish. Add XML code into the Class Editor window to complete the XData block.

The New XData wizard prompts you for the following information (you can later modify any of these values):

XData Name

(required) Name of the new XData. This name must be a valid name and must not conflict with the name of a
previously defined XData.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new XData.

For details, see “XData Definitions”  in the Class Definition Reference.
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11
Adding SQL Triggers and Foreign Keys
to a Class

Every persistent InterSystems IRIS class is automatically projected as an SQL table. This chapter discusses how you can
use Studio with those parts of a class definition that control its SQL behavior.

Also see “Using Triggers”  and “Using Foreign Keys”  in Using InterSystems SQL. For details, see “Trigger Definitions”
and “Foreign Key Definitions”  in the Class Definition Reference.

11.1 SQL Aliases
You can give classes as well as most class members an alternate name for use by SQL. This is useful because:

• There is a long list of SQL reserved words that cannot be used as identifiers.

• InterSystems IRIS does not support the underscore character in class or class member names.

To specify an SQL table name for a class, view the Class information in the Class Inspector and edit the value for the
SqlTableName keyword.

To specify an SQL name for a class member, select the desired property in the Class Inspector and edit the value for its
appropriate SQL name keyword (such as SqlFieldName for properties and SqlName for indices).

11.2 SQL Stored Procedures
An SQL stored procedure is an InterSystems IRIS method or class query than can be invoked from an ODBC or JDBC
client as a stored procedure.

InterSystems IRIS supports two styles of SQL stored procedure:

• Procedures based on class queries.

• Procedure based on class methods and that do not return a result set.
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11.2.1 Query-Based Stored Procedure

To create an SQL stored procedure that returns a result set, add a query definition to a class definition and then set the
query's SqlProc keyword to true. Do this as follows:

1. Select Class > Add > Query to open the New Query Wizard.

2. Complete the wizard to add a new query to the class definition.

3. Using the Class Inspector, set the value of the query definition keyword SqlProc to True.

You should end up with something similar to:

Class Employee Extends %Persistent 
{

/// A class query listing employees by name.
Query ListEmployees() As %SQLQuery(CONTAINID = "1") [SqlProc]
{
    SELECT ID,Name
    FROM Employee
    ORDER BY Name
}
}

You can invoke this stored procedure from an ODBC or JDBC client using a CALL statement:

CALL Employee_ListEmployees()

Following this call, the ODBC or JDBC application can fetch the contents of the result set returned by the class query.

Note that you can use this same technique with query definitions that are based on custom-written code; you are not limited
to defining stored procedures solely based on SQL statements.

11.2.2 Creating Method-Based Stored Procedure

To create an SQL stored procedure that does not return a result set, add a class method to a class definition and then set the
method's keyword SqlProc to True. Do this as follows:

1. Create a class method in a class definition using the New Method wizard.

2. Using the Class Inspector, set the value of method's keyword SqlProc to True.

You should end up with something similar to:

Class Employee Extends %Persistent
{

  ClassMethod Authenticate(
        ctx As %SQLProcContext,
        name As %String,
        ByRef approval As %Integer
        ) [SqlProc]
  {
    // ...
    Quit
  }

}

Note that the first argument of a method used as an SQL stored procedure is an instance of a %SQLProcContext object. For
more information, see the chapter “Defining and Using Stored Procedures”  in Using InterSystems SQL.

You can invoke this stored procedure from an ODBC client using a CALL statement:

CALL Employee_Authenticate('Elvis')
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To invoke this stored procedure from a JDBC client, you can use the following code:

prepareCall("{? = call Employee_Authenticate(?)}")

11.3 Adding SQL Triggers to a Class
An SQL trigger is code that is fired by the SQL Engine in response to certain events.

Note that SQL triggers are not fired during object persistence (unless you are using %Storage.SQL storage class).

You can add an SQL trigger to a class definition in two ways:

• Editing the class definition using the Class Editor.

• Using the New SQL Trigger wizard

To add an SQL trigger using the Class Editor, position the cursor on a blank line in the Class Editor and enter a trigger
declaration such as:

Class MyApp.Company Extends %Persistent 
{

/// This trigger updates the Log table for every insert
Trigger LogEvent [ Event = INSERT ]
{
    // ...
}

}

11.3.1 New SQL Trigger Wizard

You can use the New Trigger wizard to create a new SQL trigger. You can open the New SQL Trigger wizard using Class

> Add > SQL Trigger. Alternatively, right-click in the Class Inspector and select Add > New SQL Trigger .

The New SQL Trigger wizard prompts you for information. Select Finish at any time (default values are provided for any
information you have not specified).

11.3.1.1 Name and Description Page

The New SQL Trigger wizard prompts you for the following information (you can later modify any of these values):

Trigger Name

(required) Name of the trigger. This name must be a valid trigger name and must not conflict with the name of a
previously defined trigger.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new trigger. This description is used when the class' documentation is displayed in
the online class library documentation.

11.3.1.2 Trigger Event Page

The New SQL Trigger wizard asks you to indicate when you want the new trigger to be fired by specifying the event and
time for the trigger.
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Event Type

This specifies which SQL event fires the trigger. The choices are Insert (when a new row is inserted), Update
(when a row is updated), or Delete (when a row is deleted).

Event Time

This specifies when the trigger is fired. The choices are Before or After the event occurs.

11.3.1.3 Trigger Code

The New SQL Trigger wizard lets you enter the source code for the trigger if you want.

11.3.1.4 Results of Running the New SQL Trigger Wizard

After you finish using the New SQL Trigger wizard, the Class Editor is updated to include text for the new trigger definition.

You can edit the trigger using either the Class Editor or the Class Inspector.

11.4 Adding New SQL Foreign Keys to a Class
An SQL foreign key defines an integrity constraint between one or more fields in a table and a key (unique index) in another
table.

Object applications typically do not use foreign keys; they instead use relationships, which offer better object-based navi-
gation. Relationships automatically impose integrity constraints (for both SQL and object access) that are equivalent to
manually defining foreign key definitions.

Typically you use foreign key definitions in applications that are originally purely relational in nature.

You can add an SQL foreign key to a class definition in two ways:

• Editing the class definition using the Class Editor.

• Using the New SQL Foreign Key wizard

To add an SQL foreign key using the Class Editor, position the cursor on a blank line in the Class Editor and enter a foreign
key declaration such as:

Class MyApp.Company Extends %Persistent 
{

Property State As %String;

ForeignKey StateFKey(State) References StateTable(StateKey);

}

11.4.1 New SQL Foreign Key Wizard

Open the New SQL Foreign Key wizard using the Class > Add > Foreign Key. Alternatively, you can right-click the Class

Inspector and select Add > New Foreign Key. You can also click the New Foreign Key button  from the toolbar.

The New SQL Foreign Key wizard prompts you for information. When you have filled in the required information, select
Finish (default values are provided for any information you have not specified).

48                                                                                                                                                                         Using Studio

Adding SQL Triggers and Foreign Keys to a Class



11.4.1.1 Name and Description Page

The New SQL Foreign Key wizard prompts you for the following information (you can later modify any of these values):

Foreign Key Name

(required) Name of the foreign key. This name must be a valid foreign key name and must not conflict with the
name of previously defined foreign key.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Description

(optional) Description of the new foreign key. This description is used when the class' documentation is displayed
in the online class library documentation.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

11.4.1.2 Attributes Page

The second page of the wizard asks you to select one or more properties of the class that you want constrained by the foreign
key.

11.4.1.3 Key Construction Page

The third page of the wizard asks you to select both the class and a key (unique index) in that class that specify the values
used to constrain the foreign key properties.

11.4.1.4 Results of Running the New SQL Foreign Key Wizard

After running the New SQL Foreign Key wizard, the Class Editor is updated to include the new foreign key definition.

You can make changes to this foreign key using either the Class Editor or the Class Inspector.
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12
Adding Storage Definitions to a Class

The physical storage used by a persistent or serial class is specified by means of a storage definition. You can use Studio
to view and edit such storage definitions.

Note: Storage definitions are a fairly advanced feature of InterSystems IRIS objects. In most cases, you do not need to
work with storage definitions; the InterSystems IRIS class compiler automatically creates and manages storage
definitions for persistent objects.

If you use storage definitions, you typically work with them in the following cases:

• You need detailed control over the storage used by a persistent object, perhaps for performance tuning.

• You are mapping an object definition on top of a preexisting data structure.

A class can have any number of storage definitions, though only one can be used at one time. A new class does not have
a storage definition until either you save and compile the class or you explicitly add one to the class. You can add a new
storage definition to a class using Class > Add > Storage.

Note: Compiling a class automatically generates its storage definition. Only persistent and serial classes have storage
definitions.

Within Studio, you can view and edit the storage definitions for a class in two different ways:

• Visually using the Storage Inspector in the Class Inspector window: select Storage in the Class Inspector and select
the desired storage definition.

• Textually using the Class Editor; the storage definition is in the body of the class definition.

These techniques are described in the following sections.

12.1 Adding Storage Definitions to a Class
You can add a new storage definition to a class definition in two ways:

• Adding a storage definition to the class definition using the Class Editor and Class > Add > Storage.

• Using the New Storage wizard.
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12.1.1 Using the New Storage Wizard

You can use the New Storage wizard to add a new storage definition to a class definition. You can start the New Storage
wizard using Class > Add > Storage. Alternatively, right-click in the Class Inspector and select Add > New Storage . You

can also click the New Storage button  from the toolbar.

The New Storage wizard prompts you for information. Select Finish at any time (in this case, default values are provided
for any information you have not specified).

12.1.1.1 Name,Type, Description Page

The New Storage wizard prompts you for the following information (you can later modify any of these values):

Storage Name

(required) Name of the new storage definition. This name must be a valid class member name and must not conflict
with the name of a previously defined storage definition.

See the section “Class Members”  in the appendix “Rules and Guidelines for Identifiers”  in the Orientation Guide
for Server-Side Programming.

Storage Type

(required) Type of storage used by this storage definition. The type specifies which storage class is responsible
for implementing the storage interface for this class. The choices are:

• Storage—this storage definition is based on the %Storage.Persistent class. This is the default storage type
used for new persistent classes.

• SQL Storage—this storage definition is based on the %Storage.SQL class. This storage type uses SQL state-
ments to perform storage operations. This storage type is used for mapping objects to existing data structures
or to communicate with remote RDBMS via the InterSystems SQL Gateway.

• Custom Storage—this storage definition is based on a user-defined storage class.

Description

(optional) Description of the new storage definition.

A description may include HTML formatting tags. See “Creating Class Documentation”  in Defining and Using
Classes.

12.1.1.2 Global Characteristics of a %Storage.Persistent Definition Page

For a %Storage.Persistent storage definition, the New Storage wizard lets you specify some characteristics of the globals
(persistent multidimensional arrays) used to store the data and indices for the persistent class. These characteristics include:

DataLocation

Name of the global as well as any leading subscripts used to store instances of the persistent class. For example,
to specify that data should be stored in the global ^data, enter ^data in this field. To specify that data should be
stored in the global subnode ^data("main"), enter ^data("main").
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IndexLocation

Name of the global as well as any leading subscripts used to store index entries for the persistent class. By default,
indices are stored in the Index Reference global with an additional subscript based on the Index name. You can
override this on an index-by-index basis.

IdLocation

Name of the global as well as any leading subscripts used to contain the default object ID counter. The object ID
counter is used to maintain the ID number of the next object instance of this type.

12.2 Using the Class Inspector with Storage Definitions
You can use the Class Inspector to visually view and edit a class' storage definition. The Class Inspector displays a list of
storage definitions in the same way that it displays methods or properties.

To view an existing storage definition in the Class Inspector:

1. Select the Class Inspector.

2. Select Storage in the Inspector's Member list pull-down.

3. Double-click a storage definition.

At this point, the Class Inspector displays storage keywords along with their values.

Several of the storage keywords warrant special attention:

Data Nodes

Represents the set of data mappings used by the %Storage.Persistent storage class. The Data Nodes editor, which
you can invoke by double-clicking on the Data Nodes keyword, allows you to view and edit the set of data node
specifications for the storage definition: that is, you can directly specify how your class' properties are stored in
global nodes.

SQL Storage Map

Represents the set of data mappings used by the %Storage.SQL storage class. The SQL Storage Map editor, which
you can invoke by double-clicking the SQL Storage Map keyword, allows you to view and edit the set of
mappings used to map object properties to existing data structures.

12.3 Using the Class Editor with Storage Definitions
You can use the Class Editor to view and edit a class' storage definition. You can toggle the display of a class storage defi-
nitions using View > Expand Code.

A storage definition is displayed as an in-line XML island in the body of the class definition using the same XML elements
that are used in the external, XML-representation of a class definition.

For example, suppose you have a simple persistent MyApp.Person class:
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/// A simple persistent class
Class User.Person Extends %Persistent 
{
Property Name As %String;
Property City As %String;
}

After compiling this class (to ensure that the class compiler has created a storage definition for it), display its storage defi-
nition using the View > Expand Code (or select plus icon next to the top line of the block). This results in following display
in the Class Editor:

/// A simple persistent class

Class User.Person Extends %Persistent
{

Property Name As %String;

Property City As %String;

Storage Default
{
<Data name="PersonDefaultData">
    <Value name="1">
        <Value>%%CLASSNAME</Value>
    </Value>
    <Value name="2">
        <Value>Name</Value>
    </Value>
    <Value name="3">
        <Value>City</Value>
    </Value>
</Data>
<DataLocation>^User.PersonD</DataLocation>
<DefaultData>PersonDefaultData</DefaultData>
<IdLocation>^User.PersonD</IdLocation>
<IndexLocation>^User.PersonI</IndexLocation>
<StreamLocation>^User.PersonS</StreamLocation>
<Type>%Storage.Persistent</Type>
}

}

The XML storage definition includes all the defined storage keywords and their corresponding values represented as XML
elements.

You can directly edit this definition in the Class Editor as you would any other part of the class definition. If you enter
invalid XML syntax, the editor colors it as an error.

The storage definition can be useful in cases where you need to do simple or repetitive modifications.

For example, suppose you want to change the name of a property City to HomeCity, while preserving the physical storage
layout (that is, you want the new property name to access the values stored with the old name). You can do this using the
Class Editor as follows:

1. Load the class definition into a Studio Class Editor window and display its storage.

2. Use the Editor's Replace command to replace all occurrences of the property City with HomeCity. You must be careful
to only change those occurrences of City that represent the property name (such as in the property definition, method
code, descriptions, and in the body of the storage definition); do not replace the values of any class definition keywords.

3. Save and recompile the class definition.
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13
Working with CSP Files

Using CSP files with InterSystems IRIS is not recommended.

When working with other InterSystems products, a CSP (Web Server Page) file is a text file containing HTML, XML, or
CSP markup commands. This file is stored on an InterSystems server machine and is compiled, by the CSP Engine, into
an executable class that can process HTTP events sent from a browser.

You can use Studio to create and edit CSP files in the same way you would work with class definitions or routines. CSP
files are displayed in the Studio syntax-coloring editor, allowing you to quickly spot errors in HTML as well as in any
embedded server-side scripts.

13.1 Sample CSP Page
To create a simple CSP page with Studio, perform the following steps:

1. Start Studio and create a new Project.

2. Select File > New > CSP File tab > Server Page to create a new CSP page.

3. Studio creates a new CSP Editor window containing a new CSP file named Untitled.csp.

Replace the contents of the editor window with:

<HTML>
<HEAD>
<TITLE>Sample Page</TITLE>
</HEAD>
<BODY>
My Sample CSP Page.
</BODY>
</HTML>

4. Save the page with File > Save. The Save As dialog appears. Specify a directory location and project name, and select
Save As.

5. Compile the page with Build > Compile .

6. View the resulting Web page from a browser with View > Web Page.

At this point, you should see a very simple Web page containing the words My Sample CSP Page in your browser.

To make this example more interesting, we can add an SQL query to the page that executes when the page is requested:

1. Position the cursor in the CSP Editor window at the start of the blank line after My Sample CSP Page.

2. Select Insert > SQL Query.
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3. In the dialog that appears enter the following SQL query:

SELECT Name,SSN FROM Sample.Person ORDER BY Name

4. Check Create HTML Table and select OK.

5. Save and recompile the page with Build > Compile.

6. View the resulting Web page from a browser with View > Web Page .

Now your CSP page displays a list of names and social security numbers in an HTML table.

13.2 Creating a New CSP File
To create a new CSP file, select File > New > CSP File tab > Server Page. This creates a new CSP file named Untitled.csp.

When you save this file for the first time, you are asked for a file name. If this file is part of a CSP application, create a
folder with an application name, in which to put your new file.

The file name, which must have a .csp extension, is used for both saving a physical source file on the InterSystems server
as well as in a URL requesting this page. The application name also determines the URL used to request the CSP page as
well as other characteristics.

13.2.1 Default.csp Template File

When you create a new CSP file in Studio, it opens a new CSP Editor window and copies into it the contents of a CSP
template file. You can edit or replace this template file in order to customize how Studio creates new CSP files. This file
is a text file called Default.csp and is located in the same directory as the Studio executable file.

13.3 Editing a CSP File
You can edit a CSP file in the same way you would edit any other document in Studio.

13.3.1 Insert Options

Studio includes dialogs, a wizard, and templates to assist with editing CSP files. These dialogs are available under the Insert

menu and are described in the table below.
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ActionInsert Menu
Option

Inserts a <csp:CLASS> tag at the current cursor location.Class

Inserts a <csp:LOOP> tag at the current cursor location.Loop

Inserts a <csp:WHILE> tag at the current cursor location.While

Inserts an InterSystems objects method (in a <SCRIPT> tag) at the current cursor locationMethod

Inserts a <csp:OBJECT> tag at the current cursor location.Object

Inserts a <csp:QUERY> tag at the current cursor location.Query

Inserts an SQL query (in a <SCRIPT> tag) at the current cursor location.SQL Query

13.4 Saving a CSP File
Save a CSP file using the File > Save. This sends the source of the CSP file back to the InterSystems server (which could
be on a remote machine) and save it on the server's local file system in the appropriate directory (specified by the InterSystems
server's CSP application settings). Studio automatically saves backup files for the five previous saves of a CSP file. For
more information, see Save Automatically Backs Up Routines, Include Files.

13.5 Compiling a CSP File
Compile a CSP file using Build > Compile. Compiling a CSP File is a multi-step process: first the CSP file is fed through
the CSP engine and converted into a class (derived from the %CSP.Page class). Then this generated class is compiled into
one or more routines that contain executable code.

Sometimes it is easier to debug or understand a CSP file by looking at the code generated for it. You can use Studio to view
the class generated for a CSP file, as well as the routines generated from this class, by opening them with File > Open or
View > Other.

13.6 Viewing the Results of a CSP File
You can view the results of a CSP file in a browser by using View > Web Page. This launches your default browser with
the URL for the current CSP page. You can also use this command when editing a %CSP.Page class.

You can modify the server address portion of the URL used to display a CSP page in a specific project. To do this, select
Project > Settings and edit the value of the WEB Server field.
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13.7 Viewing Syntax-Colored Source for Any URL
As an aid to debugging Web applications, Studio lets you request a web page from a URL and display its HTML source
in a syntax coloring window. This can help you spot errors in web pages more easily than viewing the rendered HTML in
a browser.

You can open a URL Viewer window using the File > Open URL and entering a URL in the resulting dialog. You can use
the URL viewer to view syntax-colored source for any Web page on the Internet
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14
Working with Routines and Include Files

A routine is the unit of execution in an InterSystems IRIS server; all application logic running on an InterSystems IRIS
server is executed by invoking routines and entry points in routines. Routines are executed in a virtual machine that is built
into the InterSystems IRIS server environment. Routines are portable to all platforms supported by InterSystems IRIS and
automatically shareable across an InterSystems IRIS environment.

Include files (.inc files) contain macro definitions (or other include files) and can be included in .mac routines or class def-
initions. For more information on macros, see the section “Using Macros”  in Using ObjectScript.

14.1 Routine Editor
Using the Routine Editor, you can directly create and edit the source for routines or include files. The Routine Editor uses
syntax coloring and indicates syntax errors with a wavy red line.

When class definitions are compiled, the class compiler generates a set of routines containing the implementation for the
class. If you want to view and edit this generated source code, you must specify that the compiler should keep a copy of
the generated code. To keep a copy of the generated code:

1. Select Tools > Options.

2. Navigate to Compiler > Flags & Optimization in the left-hand pane.

3. Select Keep Generated Source Code.

14.2 Routine Source Formats
There are several kinds of routine source formats (files) in InterSystems IRIS. The Routine Editor provides syntax coloring
and checking for each of these formats. The formats include:

• MAC - Macro source files with a .mac extension, processed by the InterSystems IRIS macro preprocessor to resolve
macros, embedded SQL statements, and embedded HTML, which results in an .int file.

• INT - Intermediate source files, which are compiled directly into executable InterSystems IRIS object (OBJ) code.

• INC - Include files. Not routines per se, .inc files contain macro definitions that can be included by .mac routines.

By default, when you create a new ObjectScript routine, it is saved as a .mac routine. Select File > Save As to save this as
a different type of routine (changing the extension from .mac to .inc for example).
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Select View > View Other to display .int code corresponding to a given .mac file and vice versa.

14.3 Creating a New Routine or Include File
To create a new routine or include file, select File > New. A dialog displays the templates you can choose from. For an
include file, select ObjectScript. This opens a new Routine Editor window with a default name, such as Untitled. You can
save this with a different name with File > Save As.

14.4 Opening an Existing Routine or Include File
Open an existing routine with File > Open . In the drop-down list of Files of Type , select the file extension of interest (such
as .mac, .int, or All Files) and select a routine.

When you attempt to open a previously saved routine or include file, the Open dialog uses wildcard matching (using the *
(asterisk to match any number of any character) and ? (question mark to match a single character) to display a list of
available routines or include files. The routine type - BAS, MAC, INT, or INC - is used as a file extension for purposes of
wildcard matching.

14.5 Routine Template File
When you create a new routine in Studio, it opens a new Routine Editor window. If a Routine template file exists, it is
copied into the new file. To create a Routine template file, create a file with the contents that you want in your template.
Save the file as Default.mac in the same directory as the Studio executable file (CStudio.exe).

14.6 Saving, Compiling, and Deleting Routines
You can save routines to the database by selecting File > Save or File > Save As. By default, saving a routine does not cause
it to be compiled. To change this behavior so the routine is compiled every time it is saved:

1. Select Tools > Options.

2. Navigate to Compiler > Behavior in the left-hand pane.

3. Select Compile Routine on Save.

To compile a routine directly, select Build > Compile (which also causes it to be saved).

To delete a routine, in a Workspace window, highlight the routine and select Edit > Delete. The routine and any generated
files are deleted.
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14.7 Save Automatically Backs Up Routines and Include
Files
When you save an existing routine (or include file), Studio automatically creates a backup file. It automatically saves up
to five backup files, naming them with a ;# (semicolon number) suffix. For example, a file named setup.MAC which has
been saved six times has five backup files named:

setup.MAC;1
setup.MAC;2
setup.MAC;3
setup.MAC;4
setup.MAC;5

Specifically, files with the following extensions are automatically backed up: .BAS, .INC, .INT, .MAC, .OBJ, .MVB, .MVI,
.CSP

To see what backup files exist, use a semi-colon in the search field of the File > Open option. You can use the following
syntax examples:

ResultsSyntax

Displays all backup files in this folder.*.*;*

Displays all backup files with a .MAC extension.*.mac;*

Displays all backup files named setup.setup.*;*

Note: You can use this syntax to find backup files when you are opening routine and include files from the Management
Portal. To open backup files from the Management Portal:

1. Select Management Portal from the InterSystems IRIS launcher.

2. Select System Explorer > Routines.

3. Click Go.

4. Enter the backup file syntax in the Routines and Include Files search box in the left-hand pane.
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15
Using the Studio Debugger

The Studio debugger lets you step through the execution of programs running on an InterSystems IRIS server. Programs
that can be debugged include INT files, BAS files, MAC files, methods within CLS files, server-side methods invoked
from Java, or server-hosted applications. To step through, or set breakpoints within classes, open the corresponding INT
or BAS file and use the debugging commands in it. Before you can view INT source code files, you must:

1. Select Tools > Options.

2. Navigate to Compiler > Flags & Optimization in the left-hand pane.

3. Select Keep Generated Source Code.

You can connect the debugger to a target process in one of the following ways:

• Select Debug > Attach and choose a running process on an InterSystems IRIS server. To attach to a running process,
you must have either the %ALL role or the same $USERNAME as the process you are trying to debug.

• Define a debug target (name of program or routine to debug) for the current project using Project > Settings > Debugging

> Debug Target (or Debug > Debug Target). Then select Debug > Go to start the target program and connect to its server
process.

Note: Sometimes using command-line debugging with the zbreak command can give you better control. For more
information on zbreak, see the chapter “Command-Line Routine Debugging”  in Using ObjectScript.

15.1 Sample Debugging Session: Debugging a Routine
The following example demonstrates how to debug a routine.

1. Start Studio and select File > New Project to create a new project called Project1.

2. Create a new routine by selecting File > New > General tab > ObjectScript Routine.

3. Enter code for this routine:

MyTest ; MyTest.MAC

Main() PUBLIC {
    Set a = 10
    For i = 1:1:10 {
        Set b = i
             Write b," "
    }
}
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4. Save and compile the new routine as MyTest.MAC using File > Save As.

5. Define a debug target for the project by selecting the Debug > Debug Target tab, selecting Class Method or Routine,
and entering the name of the entry point in your new routine, Main^MyTest.

6. Set a breakpoint in the routine: Position the cursor anywhere on the line Set a = 10 and press F9, the Toggle

Breakpoint key. A breakpoint indicator appears in the left margin, .

7. Select Debug > Go to begin debugging. When the debugger stops at your breakpoint, the next command to be executed
is outlined with a yellow box. The INT file opens in a new window. If the INT file does not open, make sure you have
enabled the Keep Generated Source Code option. (Select Tools > Options, click Compiler > Flags & Optimization in the
left-hand pane, and select Keep generated source code.)

8. Enter b and a (as Watchpoints) in the Watch window (View > Watch) so that you can watch the values.

9. Step through execution of the program by repeatedly selecting Debug > Step Into (F11) and notice the b value change.

You can stop debugging by stepping to the end of the program or by selecting Debug > Stop.

15.2 Debugger Settings for the Current Project
Some debug settings are defined and stored in the current project. These include:

• Debug target

• Breakpoints

15.2.1 Debug Target

A debug target tells Studio what process you want to debug.

To specify a debug target for a project, select Project > Settings > Debugging > Debug Target or select Debug > Debug Target.
Choose one of the following, which is started when you select Debug > Go. You can also set a debug target by placing the
cursor next to an item in a editor window, right-clicking, and selecting Set xxxx as debug target.

Class Method or Routine

The routine (and tag), class, or method that you want to debug when Debug > Go is executed. For example, enter
Test^MyRoutine() to begin execution at the tag Test in the routine MyRoutine. Or enter the name of a class
method to execute, such as ##class(MyApp.Person).Test(1).
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CSP Page (URL, CSP or class)

The CSP page to be accessed when you invoke Debug > Go. The debugger connects to the InterSystems server
process that is servicing the CSP page's HTTP request. Use this option for debugging CSP applications, for
example, to step through the code for the Test.csp page, enter /csp/user/Test.csp as a debug target. Using CSP
files with InterSystems IRIS is not recommended.

15.2.2 Breakpoints

When you start debugging a project's debug target (with Debug > Go), the breakpoints defined by the project are set in the
target process.

The quickest way to set and remove a breakpoint is to place the cursor on the line of code and press F9 to toggle the
breakpoint on and off. You can also place the cursor at the breakpoint location and select Debug > Breakpoints > Toggle

Breakpoint. To view breakpoints and set breakpoints with conditions, select Debug > Breakpoints > View Breakpoints. You
can also add or remove breakpoints using Project > Settings > Debugging > Breakpoints.

Note: The maximum number of breakpoints that can exist in a routine is 20. If more than 20 breakpoints are set, the
Debugger displays <ROUTINELOAD>^%Debugger.System.1 and stops debugging.

15.3 Debug Menu
Debug menu options are described below:

Displays a list of processes currently running on the InterSys-
tems server and lets you attach to one to debug.

If you select a process and select OK, Studio breaks into the
selected target process and allows you to start debugging it.

If you generated source for the current routine executing in
the target process, the source is displayed in an editor window.

If you later terminate debugging with Debug > Stop, the target
process resumes executing.

Attach

If you are not currently debugging, Go starts the target specified
by the Project's debug target.

If you haven't set a target, you are asked for one. A debug
target is the name of routine or method to execute; you can
set this using the Debug Target dialog.

Once the target is started, it runs until the first breakpoint. If
you did not set any breakpoints in your application, it runs to
completion without stopping.

Go

Halts execution of the target process, restarts it, and resumes
debugging (as if the Go command was used).

Restart
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Stops debugging and either halts the target process or
detaches from it. If the target process was running and
attached to with Attach, then the target process continues
running. If the target process was started as a result of the Go

command, then it is terminated.

Stop

Pauses execution of the target process (that is, if the debugger
is attached to a target process that is currently running, not
stopped).

Break

Interrupts execution of the current command.Interrupt

Executes the current command in the target process and stops
on the next command, stepping into any function calls or loop
bodies.

Step Into

Executes the current command in the target process and stops
on the next command. The debugger steps over any function
calls or code blocks (such as loops) it encounters; it stops on
the command following the function call or code block.

Step Over

Advances the execution of the target process by leaving or
stepping out of the current code block or function and stops
on the next command at this outer level.

Step Out

Available only for documents containing INT routines.

Starts execution of the target process and stops when it
reaches the line on which the cursor is currently located. This
is equivalent to setting a breakpoint at the current line in the
editor window, executing the Go command, and clearing the
breakpoint when the program halts.

Run To Cursor

Toggle Breakpoints Sets or clears a breakpoint on the current
line in the current document.

View Breakpoints: Opens the Breakpoints dialog with which you
can list, add, and remove breakpoints.

Breakpoints

Enter a debug target – a method or routine. See also “Debug
Target ” .

Debug Target

15.4 Watch Window
The Watch Window displays a table in which you can watch the values of variables and simple expressions. All variables
and expressions listed in the Watch Window (called watchpoints) are evaluated after each debugger operation (such as Step

Over) and their resulting values are displayed in the second column of the Watch Window. If the value of a variable or
expression changes after a debugger operation, it is displayed in red. If a variable in the watch list is undefined when it is
evaluated, then the value is displayed as: <UNDEFINED>. Similarly, any expression whose result is an error displays an
error message for its value. You can also see the value of a variable by hovering your mouse over the variable in the
debugger.
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To add a variable or expression to the Watch Window, double-click an empty cell in the first column and enter the variable
or expression. Alternatively, you can use your mouse to highlight text in an editor window, drag it over an empty cell in
the Watch Window and drop it. You can edit the contents of the Watch Window by double-clicking on a variable or
expression and typing.

The following are examples of variables and expressions you could enter into the Watch Window:

• a

• a + 10

• a(10,10)

• $L(a)

• person.Name

You can also change the value of a variable in the target process by entering a new value in the Value column of the Watch
Window.

15.4.1 Debugger Watch Window Context Menu

Right-clicking a debugger watch window displays the following context menu:

Removes the active variable from the watch list.Remove

Select view type from list.View As

Displays result of %SYSTEM.OBJ.Dump() on selected
variable.

Dump Object

Refreshes the watch list.Refresh

Removes all active variables from the watch list.Remove All

Adds selected element of array or object property to
be added to watch menu as an independent entry.

Add to Watch
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16
Using Studio Templates

This chapter describes how to use Studio Templates.

Templates are a repeatable way to insert functionality into Studio editor windows. There are two types of templates:

• Text Template—(what is meant by the word Template) A Simple Text Template inserts generated text into a document.
An Interactive Text Template includes user input. To access text templates, select Tools > Templates > Templates....

• Add-in Template—Creates a new tool in Studio. An Add-in Template differs from a Text Template in that it does not
inject text into a document and does not require an open document.

Add-ins are available using Tools > Add-ins. For information on using the SOAP Web client wizard, see Creating Web
Services and Web Clients. For information on using the XML Schema Wizard, see the appendix “Using the XML
Schema Wizard”  in Using XML Tools.

Note: To ensure that Studio templates open quickly, disable the automatic detection of proxy settings in Internet Explorer.

1. Open Internet Explorer and select Tools > Internet Options and the Connections tab.

2. Select LAN Settings and uncheck any checked boxes. Make sure nothing on this page is checked and then
select OK twice to close the Internet Options dialog.

16.1 Accessing Studio Templates
You can open a template using Tools > Templates, as well as with the right-click menu in the editor window. Each template
is associated with one or more document types; only templates associated with the current window's document type are
shown in the Template list.

There are two styles of text templates: simple and interactive. A simple template inserts text at the cursor point with no
further user interaction. An Interactive Template displays one or more screens soliciting additional information, like a
wizard.

Any text that is highlighted when you open a template is replaced by the template. Many templates use the currently high-
lighted text as input to the template program.
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16.2 Standard Studio Templates
Studio comes with a set of templates. You can see a list of all templates in Studio in the %SYS namespace, Workspace

window, Namespace tab, under CSP files. To see templates usable in the current document, use Tools > Templates > Templates.
These templates are described below.

Note: By default, Studio templates use a session timeout of 90 seconds. If you are entering data into a Studio template,
the session ends after 90 seconds of no user input.

16.2.1 Templates

This section contains three tables defining the templates available in Studio:

Table 16–1:Templates

DescriptionTemplate

Select to insert an HTML color value string (such as #F0F0F0) at the cursor point.HTML Color

Select to insert an HTML input control at the cursor point.HTML Input

Select to insert a <SCRIPT> tag at the cursor point, with the specified language and
content.

HTML Script

Select to insert an HTML table at the cursor point with the specified characteristics.
Select Preview to display a preview window.

HTML Table

Select to insert an HTML tag at the cursor point, selected from a list with specified
attributes. Or if you highlight an existing HTML tag and then invoke the template, you
can edit the displayed attribute values.

HTML Tag

Figure 16–1: Example of an Interactive Template, the HTML Color Table

16.2.2 Class Definition Templates

Many of the templates are available for use in class definitions (they can be useful in &html<> blocks). In addition, the
following templates are available:
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Table 16–2: Class Definition Templates

DescriptionTemplate

Select to insert code for a specified SQL Statement at the cursor point. Select Preview

to see test results of the table (using data in the database) in a popup preview window.
You can specify whether the template returns only the SQL text or an embedded SQL
cursor based on the SQL text. It can also return a %ResultSet object based on the
SQL text, but this is not recommended in InterSystems IRIS.

SQL Statement

Select to open a Wizard with which you can create a CSP form, specifying class
members and a table style for the form to use.

Web Form Wizard

16.2.3 Add-In Templates

The Tools > Add-Ins menu contains a list of wizards with which you can add items to your project. The menu contains the
following add-ins.

Table 16–3: Add-Ins

For More InformationFunctionAdd-In

Using the Object Gateway for
.NET

Imports a DLL assembly file from .NET and
creates a set of corresponding classes.

.Net Gateway Wizard

For documentation on this wizard,
click here.

This wizard option is not for use with
InterSystems IRIS.

Activate Wizard

Using the Java GatewayImports a class file or a jar file from Java and
creates a set of corresponding classes.

Java Gateway
Wizard

Creating Web Services and Web
Clients

Reads a WSDL (Web Services Description
Language) document and creates one or more
Web client classes or Web service classes.

SOAP Wizard

“Using the XML Schema Wizard ”
in Using XML Tools.

Reads an XML schema and creates a set of
corresponding classes.

XML Schema wizard

“Performing XSLT
Transformations ”  in Using XML
Tools.

Transforms an XML file using a specified XSL
stylesheet.

XSL Translate
Wizard
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17
Studio Menu Reference

This chapter describes menu and keyboard options available from the Studio menus. The menus are:

• File

• Edit

• View

• Project

• Class

• Build

• Debug

• Tools

• Utilities

• Window

• Help

• Context Menus

• Studio Editor Keyboard Accelerators

17.1 File Menu
The File menu contains options for opening and saving documents and projects. Options vary depending on whether a file
is open. See also the section “Keyboard Accelerators.”

Use to connect to a different InterSystems IRIS server.New Studio

Use to change to a different namespace.Change Namespace ...
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Use to create a new document (such as class definition or
routine) in an editor window.You can also drag and drop files
into Studio. Document types are grouped under four tabs:

• General - for creating a new ObjectScript routine, InterSys-
tems IRIS class definition (with the New Class wizard),
Web Service/Client Configuration, or Web Service.

• CSP File - for creating a new Web Server Page, XML file,
JavaScript file, or cascading style sheet (CSS) file. Using
CSP files with InterSystems IRIS is not recommended.

• Zen— for creating a new Zen application, component, page,
report, form, or Web Service. Using Zen applications with
InterSystems IRIS is not recommended.

• Custom - for a new InterSystems Business Intelligence KPI
(formerly known as DeepSee KPI). For information, see
the Advanced Modeling for InterSystems Business Intelli-
gence Guide.

New ...

Allows you to open an existing item from the current InterSys-
tems IRIS namespace and server.

The Open dialog is displayed for the current namespace. Select
a file type as needed. Press Ctrl+A to Select All.

If the item is in use by another user, you can open it for Read
Only access.

To open automatically-saved backup files, see Save Automat-
ically Backs Up Routines, Include Files.

Studio allows you to edit class definitions and routines only
from the current server and namespace. To open an item from
a different server or namespace, use File > Change Namespace

to change to a different namespace or switch to a different
server. Use File > New Studio to open a second Studio window.

If you select an item and right-click Delete, the item and all
subitems are deleted. Examples: if you select an .INT file, both
.INT and .OBJ files are deleted. If you select a .cls file, all
associated .INT and .OBJ files are deleted also.

Open ....

Displays HTML source in an editor. This is useful when you
are developing a Web-based application to view progress.

Open URL

Closes the current editor.Close

Saves the contents of the current editor.Save

Saves the contents of the current editor with a name that you
specify.

Save As ...

Saves the contents of all open windows.Save All

Creates a new project in the current InterSystems IRIS server
and namespace.

New Project
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Opens an existing project in the current InterSystems IRIS
server and namespace.You can also drag and drop a project
into Studio.

To open a project from a different server or namespace, use
File > Change Namespace to change to a different namespace or
switch to a different server. Use File > New Studio to open a
project in a second Studio window.

Open Project ...

Saves setting for the current project. It does not save any
modified documents belonging to the project.

Save Project

Saves the current project with a name you specify.Save Project As

Closes the current project.Close Project

Prints the current document.Print ...

Displays the document as it will look when printed.Print Preview

Opens the Print Setup dialog with which you can set how
documents are printed.

Print Setup ...

Lists recently used files. More shows files (if they exist) in
categories Today, Yesterday, Last 7 days, Last 30 days and All. All

is limited to 100 documents. Select Clear History to clear all.
Select Open Document to open a selected document.

Recent Files ...

Lists recently used projects.Recent Projects ...

Ends the current Studio session.Exit

17.2 Edit Menu
The Edit menu contains editing and navigation options. Most of the options have keyboard shortcuts; see the section
“Keyboard Accelerators” .
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17.2.1 Basic Editing

Reverses the last action.

Note that changes made to classes with the Class Inspector cannot be
reversed using Undo.

Undo

Reverses the most recent Undo.Redo

Deletes the current text selection and copies it to the clipboard.Cut

Copies the current text selection to the clipboard.Copy

Inserts the contents of the clipboard at the current cursor location.Paste

Deletes the current text selection without copying it to the clipboard. If
you highlight an item in the Workspace window, the item and any of its
generated files are deleted.

Delete

Selects all the contents of the current document.Select All

17.2.2 Find and Replace

Searches for text in the current document.You can use wildcard matching
with the * (asterisk to match any number of any character) and ?
(question mark to match a single character). To find the character * or
? or \ (asterisk, question mark, or backslash) , escape it with a backslash
(\). To find a tab, use \t. See the section More on Find beneath this
table to specify an element type to search within and an explanation of
the backslash escape.

Find

Searches for text in multiple files on the InterSystems IRIS server. Enter
a string to search for, select the type of file to search (such as .cls for
class definitions), and click Find. See the section Find in Files beneath
this table for specifics.

Find In Files

Searches for a class in the current project. In the Search window, type
in a class name. The list shows matching entries. To open a class,
double-click a class or select a row and click GoTo.

Search

Cancels a Find in Files search or a class compilation that is running.Cancel

Replaces one text string with another in the current document.Replace

Moves the cursor to a location in the current document, specified as
either a line number or (for routines and class definitions) a tag or class
member.

Go To

After a Go To action, returns the cursor to the previous location — before
the Go To action.

Go Back

See “Bookmarks ”  below.Bookmarks

See “Advanced ” .Advanced
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Moves the cursor to the next error in a CSP file. Using CSP files with
InterSystems IRIS is not recommended.

Next Error

Moves the cursor to the previous error in a CSP file. Using CSP files
with InterSystems IRIS is not recommended.

Previous Error

Moves the cursor to the next warning in a file.Next Warning

Moves the cursor to the previous warning in a file.Previous Warning

17.2.2.1 More on Find

Backslash Escape
The search engine normally interprets a backslash (\) as a metacharacter; that is, a character that means something other
than itself. In this case — the backslash and the following character form a two-character code. When you want to search
for the backslash itself, you need to create a two-character code since the search engine always looks for a second character
when it sees a backslash. Create a two-character code with a second backslash (\\). The search engine interprets this as the
backslash character itself.

This convention was implemented during the development of the UNIX grep command and the convention, if not the
underlying C code, has been duplicated many times since.

Match Element Type
To find text that is in a particular element type (such as a command, variable, operator, and so on), enter the desired text
in the Find what field and select the Match Element Type check box.

Note: Find displays the searched-for text in all elements of that type in the open file, regardless of language selected.
In the Language field, select the language that you are interested in to limit the number of element types shown
in the Element list. In the Element field, select the element type that contains the text you are looking for and select
Find Next.

For example, searching for the word Set in a Comment with the Class Definition Language selected matches all instances
of the word Set in comments that exist in any language in the file.

17.2.2.2 Find in Files

When you select Find in the Find in Files dialog, Studio searches the selected files in the current InterSystems IRIS
namespace and returns a list of all (up to the first 5,000) files that contain the search string. Double-click an item in the
search results to open the file and display the item, highlighted. Line & column numbers for the selected item are displayed
in the right corner of the status bar.

Find in Files searches stored data; it does not search modified open documents. If you search only in the current project
and the current project is either a new project or a modified project, you are prompted to save the project. If you refuse,
Find in Files is canceled.

To find a backslash (\) in Find in Files, you need to escape the backslash with another backslash (\\).

The Filter field can contain the elements in the list below. You can use SQL AND and OR logical operators to enter more
than one filter. For example, Type=5 AND Modified>01/01/08. The contents of the Filter field forms part of an SQL
WHERE clause. The fields come from the %Studio.OpenDialogItems class.

You can enter your own custom mask in the In files/file types field, such as al*.mac. Use a comma delimited list to enter
multiple filters in any field.

You can use the following items in the Filter field.
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UsageFilter Element

Specify 1 to find a document. Specify 0 to find a
directory.

IsTrue=1 or 0

Enter a file name to search within selected files.Name=file name

Filters for documents of a certain size. Can include
SQL relational operators.

Characters=number of characters

Type is followed by an integer which filters according
to file type list, shown in %Studio.OpenDialogItems.Type.
This can filter to a finer degree than the file type field.
To search for only .mac files, for example, enter
Type=5.

Type=#

Can include SQL relational operators.Modified=last modified timestamp

Specify 1 to find a generated file. Specify 0 to find a
user-created file.

Generated=1 or 0

Enter a description to search for within files.Description=description

17.2.3 Bookmarks

You can use bookmarks to keep track of locations in your application source. Bookmarks are stored on the local machine
in which Studio is running; they are not shared among multiple users. The bookmark options are:

Adds or removes a bookmark at the current line in the current
document.

Toggle Bookmark

Removes all bookmarks defined for the current document.Clear Bookmarks

Moves the cursor to the next bookmark in the current document.Next Bookmark

Moves the cursor to the previous bookmark in the current document.Previous Bookmark

17.2.4 Advanced Editing

The Advanced Editing menu contains some commands that are displayed in certain circumstances only.

Displays when you have an ObjectScript routine open and text is highlighted. Replaces
all abbreviated ObjectScript commands contained in the currently selected text with
their full names. For example, the following code:

S x = 10

Is replaced with:

Set x = 10

Expand Commands

78                                                                                                                                                                         Using Studio

Studio Menu Reference



Displays when you have an ObjectScript routine open and text is highlighted. Replaces
all ObjectScript commands contained in the currently selected text with their abbreviated
versions. For example:

Set x = 10

Would be replaced with:

S x = 10

Compress
Commands

Increases indent for selected lines.Increase Line
Indent

Decreases indent for selected lines.Decrease Line
Indent

Uppercases selected text.Make Uppercase

Lowercases selected text.Make Lowercase

Turns a selected line into a comment by adding a # (pound sign) to the beginning of
the line.

Comment Line

Turns a selected comment into a regular line by removing a # (pound sign) from the
beginning of the line.

Uncomment Line

Turns a selected block of text into a commented block by adding a /* (slash asterisk)
to the beginning of the block and a */ (asterisk slash) to the end of the block.

Comment Block

Turns a commented block of text into a regular block by removing the /* (slash asterisk)
from the beginning of the block and the */ (asterisk slash) from the end of the block..

Uncomment Block

Adds a tab to the beginning of each of a set of selected lines.Tabify Selected
Lines

Removes a tab from the beginning of each of a set of selected lines.Untabify Selected
Lined

17.3 View Menu
The View menu contains options that control what is displayed. Which options are shown on this menu depends on where
your cursor is. See also the section “Keyboard Accelerators.”

Shows or hides the Workspace window.The Workspace window has three
tabs:

• Project - Displays the contents of the current project.

• Windows - Displays a list of all current windows.

• Namespace - Displays the contents of the current namespace.

Workspace

Shows or hides the Inspector. The Inspector displays class definitions in
an editable table. Some aspects of class definitions can be changed in a
file only; some can be changed in a file or in the Inspector; and some can
be edited only in the Inspector.

Inspector
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Shows or hides the Output window. The Output window displays output
from the server (such as error messages resulting from compilation).You
can enter ObjectScript commands into this window; they are executed on
the server. Line & column numbers for the selected information are
displayed in the right corner of the status bar.

Output

Shows or hides the Watch window.The Watch window displays watchpoints
when debugging.

Watch

Lets you select Studio toolbars to show or hide.Toolbars

Expands Studio to occupy the full screen.Full Screen

Lets you Increase, return to Normal, or Decrease size of text in Studio.Text Size

Displays spaces, tabs, and end-of-line characters in the Editor windows.Show Special Characters

Displays line numbers.Show Line Numbers

If a document is active, reloads the saved version of current document. If
the Workspace window is active, reloads the window or project. If the
Namespace tab of the Workspace window is active, reloads the subtree
parent of the selected item; highlight the topmost level to reload the entire
tree.

Reload

Displays any source code generated by the compiler, such as .INT and
.MAC files, related to the position of the cursor. This option works only if
the current window has one or more source files currently generated for
it.

View Other Code

Displays other documents related to the current document. In some
situations, View Other Code results in the same behavior as View Other

Documents.

View Other Documents

Available only when in a CSP file.

Opens your default Web browser and displays the current CSP file, so that
you can see how your CSP pages will look as you develop Web applica-
tions.

You can change the network address portion of the URL used with Project

> Settings. The default value is http://localhost:8972.

Using CSP files with InterSystems IRIS is not recommended.

Web Page

Available only in some files. Displays complete code in text editor window.Expand Code

Available only in some files. Contracts some code sections in text editor
window. Select the plus icon to expand a section.

Contract Code

Available only in class definition files or when a class is selected. Displays
online documentation for the current class derived from the (saved)
descriptions of class members.

Show Class Documentation

Available only when you are in a source code file, such as .INT or .MAC.

Select from a list of InterSystems IRIS language versions as appropriate
for your site.

Language Mode
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17.3.1 Toolbars

The Toolbars menu lets you toggle the display of toolbars and lets you customize toolbars.

Toggles display of the Standard toolbar.Standard

Toggles display of the Debug toolbar.Debug

Toggles display of the class Members toolbar.Members

Toggles display of the status bar at the bottom of the Studio window. From left to right,
this bar shows a status message and the location of the cursor by line and column.
The four buttons on the right, if highlighted, show that the Caps Lock key is on, that the
Num Lock key is on, that the Insert key is on (Overwrite), and that the current file is a
read-only file. The status bar also displays line and column numbers for Find in Files
and Output windows, where appropriate.

Status Bar

Toggles display of the Bookmark toolbar.Bookmark

Opens the Customize dialog.Customize

Toolbars, displaying text labels, are shown below. To display text labels in Studio, choose View > Toolbars > Customize,
the Toolbars tab. Select a toolbar and select Show text labels. (If a toolbar is already selected, uncheck the toolbar, recheck
the toolbar, and check Show text labels.)

Figure 17–1: Standard Toolbar

Figure 17–2: Debug Toolbar

Figure 17–3: Class Members Toolbar

The BPL toolbar is only applicable in InterSystems IRIS.

Figure 17–4: BPL Toolbar

Figure 17–5: Bookmarks Toolbar
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17.3.2 Customize Toolbars

The Customize menu consists of four tabs for customizing parts of the Studio interface: Commands, Toolbars, Tools, and
Options.

Lists menus and all commands on Studio menus. Drag a command and drop it into
an open toolbar. To remove a command from a toolbar, drag it off the toolbar.

Commands

Select check boxes to display toolbars. Toolbars can include text labels if you select
Show text labels. The Menu Bar cannot be cleared. Select New to create a new toolbar.

Toolbars

Adds menu items to the Studio Tools menu. Specify an item name, its command, any
arguments, and its initial directory.

Tools

Select check boxes to turn on the display of screen tips, screen tips including shortcut
keys, and large icons.

Options

17.4 Project Menu
The Project menu contains options for working with projects.

Adds the item in the current editor window to the current project.Add Item

Removes the item in the current editor window from the current project.Remove Item

Select to edit settings for the current project:Settings

• General: HTTP Address used by Studio to set Web pages for this project: Set URL
location for Web pages for this project. Defines: Define a macro that is applied when
you compile the project.You can define a debug macro which can be tested by other
macros and turns on additional checking in the code. For example, debug=1 defines
the macro $$$debug to be 1.

• Debugging: Set Debug target and Breakpoints. See the chapter “Using the Studio
Debugger ”  for details.

17.4.1 Common Project Tasks

To delete a project, select File > Open Project and right-click the project that you want to delete.

To import a project, select Tools > Import Local and select the .xml  file that contains the project.

To export a project, open the project, select Tools > Export, select Export Current Project, browse to the output directory,
and enter a file name.

Project names cannot include the characters .,;/\ (that is, period, comma, semi-colon, slash, or backslash).

17.5 Class Menu
The Class menu contains options for editing class definitions and is available only when you are in a class definition file.
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The class options are arranged in an Add submenu and an Override dialog. The options include:

Select one of: Property, Method, Class Parameter, Query, Index, SQL Trigger, Foreign Key,
Storage, Projection, or XData Opens a wizard for the item and inserts an item definition
into the current class definition. See separate chapters in this book for details on options
for each of these class members.

Add

(Refactoring is available only when Studio is connected to a Windows server (it may
be Override on other platforms). Some features may partially work on non-Windows
platforms, but you should not use these features, because you may get unexpected
results.)

Override: Opens a window that lists items that the current class inherits that you can
select. It inserts an override definition into the selected class definition. Items listed
include Properties, Methods, Parameters, Queries, SQL Triggers, and XData routines.

Rename: Enter a new name. The new name replaces the old name in all locations in
the document. (Studio does not refactor code inside literal strings, such as in an
embedded SQL statement or in a method that takes a string with a column name.) . If
you check Reset Storage (for a class) or New Storage Slot (for a property), the renamed
item is created without storage and default storage is generated.You see a confirmation
box which if you choose to delete an old class, its storage extent definition is also
deleted.

Refactoring delays applying changes to the database until you are finished reviewing
changes across all documents. When you select Accept Changes, changes are saved in
a temporary location.When you select Finish all changes are applied. If you select Finish

but haven’t accepted changes to all documents, you are prompted Not all documents
modified. Proceed anyway? and you can accept changes for more documents or
finish.

Note: Do not use refactoring in a production environment. Use only during development.
Studio does not allow any data manipulation.

Refactor or
Override

Lists superclasses of the current class alphabetically.You can pick from these to Add

to Project, Show Documentation, or Open.
Superclasses

Lists classes derived from the current class (subclasses).You can pick from these to
Add to Project, Show Documentation, or Open.

Derived Classes

Displays the New Class Wizard. A class created using this option becomes a derived
class of the class in the current window and inherits its members, including properties,
methods, class parameters, applicable class keywords, and the parameters and
keywords of the inherited properties and inherited methods.

Create Subclass

A projection automatically creates related files for other languages when you compile a class. For example, adding a Pro-
jection of type %Projection.Java generates a new Java class when it compiles so that you can use your class from a Java
application.

17.6 Build Menu
The Build menu contains options for compiling and building applications. The behavior of the Build options is controlled
by the Compile settings in the Studio Options dialog (Tools > Options).
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The build options include:

Compiles the contents of the current window. Uses settings of the Compiler tab
from Tools > Options. Any messages from the compiler are displayed in the Output
Window.

If Skip Related Up-to-date Classes is enabled then:

Compile

• The current class definition is only compiled if it has been modified.

• If possible, Studio performs an incremental compile; if the only change to a
class definition is in the implementation of one or more methods, then only
these methods are compiled.

Use to select options for this session only or to change the default compile
options. Default options can also be set with the Tools > Options, Compiler tab.

Compile with Options

Compiles all the components in the current project whether or not they have
been modified from the last compile.

Rebuild All

17.7 Debug Menu
The Debug menu contains debugging options. To see the Debug Menu options, see the section “Debug Menu”  in the
chapter “Using the Studio Debugging .”  See also the section “Keyboard Accelerators.”

17.8 Tools Menu
The Tools menu contains miscellaneous options.

The tools options include:

Opens the Studio Class Browser. The Class Browser displays a list of all classes in
the current namespace as well as their members (defined and inherited).

Class Browser

Opens dialog for an SQL statement. An SQL statement selected in the active document
is displayed and editable in the dialog. Selecting Show Plan displays the query execution
plan in a web page.

Show Plan for SQL
Statement

Displays a list of Studio Templates. A template injects a stream of text at the current
cursor location. Studio provides templates. In addition, you can create your own. For
more information see the chapter on “Studio Templates ” .

Templates

Contains a list of wizards that help you add items to an open Studio file or connect to
existing files using standard formats. See the section “Add-In Templates. ”

Add-Ins

Displays a list of tasks.You can add, edit, or delete a task in the New Task window.
Each task includes a server, namespace, document name, line #, and optional
description. The current line code or selected text is used by default for the task
description. GoTo takes you to selected document and line #. If needed, Studio connects
to specified by task server/namespace using current security credentials.

Task List
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Exports one or more items (class definitions, projects, routines, include files) to either
a local file or a file on the server system.

Export

Export RO, the format created with the %RO utility.Export Special

Lets you import an item from a remote file (a file that is on the same machine as the
server that Studio is connected to). All imported items are placed into new document
windows.

You can use this option to import a project, class definition, routines, or include files
from either XML, or .RTN (%RO Routine format files).

The Import Remote option displays a dialog that lists all the items contained in the file
from which you can select.You can also specify whether the imported items should
be added to the current project and if they should be compiled.

The hand icon  indicates that the file you are importing is older than the file on the
system.

Import Remote

Lets you import an item from a local file (that is a file on the same machine as Studio).
All imported items are placed into new document windows.

You can use this option to import a project, class definition, routines, or include files
from either XML, or .RTN (%RO Routine format files).

The Import Local option displays a dialog that lists all the items contained in the file.
You can select which items you want to import.You can also specify whether the
imported items should be added to the current project and if they should be compiled.
The list of items to import must be less than 32K.

The hand icon  indicates that the file you are importing is older than the file on the
system.

Import Local

Compares an open file to one that you select with Browse.You must have specified an
external compare tool with the Compare setting in Tools > Options > Environment > General.
To work correctly, the compare tool must be able to accept command line parameters
as tool.exe file1 file2. Tested compare tools are Microsoft Windiff and Perforce
p4Diff.exe.

Compare

Creates a copy of an existing class with a new name.Copy Class

This option applies only to Cache & Ensemble.Generate C++
Projection

Opens Import and Export Studio settings wizard. In this wizard you can set file and
directory for import and export and save these settings to a text file in format compatible
with regedit.exe.This file can be imported by wizard or executed directly from command
prompt or explorer on any windows computer. Import and reset settings cause a Studio
restart. Import on Windows Vista requires administrator privileges to run.

Import and Export
Settings

Lets you set Studio options. For details on options, see the chapter “Studio Options. ”Options

Opens Customize window, in which you can customize aspects of the Studio UI, such
as menus and toolbars.

Customize
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17.9 Utilities Menu
The Utilities menu contains links to resources outside of Studio, such as:

• Management Portal

• Telnet

17.10 Window Menu
The Window menu contains standard window options for manipulating the windows in Studio.

17.11 Help Menu
The Help menu contains options for accessing online Help.

The help options include:

Displays the table of contents for Studio documentation.Studio Documentation

Displays the list of Studio options and short descriptions.Studio Commands

Displays the home page of the InterSystems IRIS Online Documentation.Online Documentation

Displays the ObjectScript online reference.ObjectScript Reference

Displays the InterSystems IRIS SQL online reference.SQL Reference

Displays the online reference for class definition syntax.Class Definition Syntax

Provides links to useful pages on the InterSystems Web Site.InterSystems on the Web

Displays version information about Studio.About Studio

17.12 Context Menus
Right-clicking areas in Studio displays different context menu. These include those described in the following sections.

17.12.1 Editor Context Menu

Right-clicking in the Studio Editor window displays a context menu. Within this context menu are many items available
from the main menus, such as on the Editor menu are Cut, Copy, Paste, Find, Toggle Breakpoint, and Go Back, and so on.
There are also additional options that are not available from the main menu. These include:
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The Help option displays context-sensitive help for selected syntactical elements. To
use, right-click text and select Help.

For example, if you right-click the word Do in ObjectScript code and select Help , the
reference page for the Do command is displayed in your browser.

Help

Opens the Add Task window, in which you can add a task to the task list. See also
Tools Menu.

Add Task

Displays a dialog in which you can choose the color used to display a specific syntac-
tical element.

To use, right-click text and select Set Syntax Color.

Set Syntax Color

Available when editing an ObjectScript routine. Lets you jump to the code that defines
the ObjectScript tag.

To use, in an ObjectScript routine, right-click a tag and select Goto <TAG> . If the right-
clicked tag is defined in another routine, Studio automatically opens this routine.

Goto <TAG>

Sets the current item as the debug target.Set current item as
debug target

Highlights all instances of the word the cursor is pointing to in the document .Toggle Word
Highlight

17.12.2 Workspace Context Menu

Right-clicking the Workspace window displays a context menu. Which menu is displayed depends on the cursor location.
Different context menus are displayed if the cursor is on a package, a class, and so on. This table below shows items on
the Workspace Package context menu not available on the menu bar.

Adds a class selected from the displayed list to the current
package.

Add

Removes the current package from this project.Remove Package “name”

Compiles the current package.Compile Package “name”

Deletes the current package.Delete Package “name”

Exports the current package to an xml file. (To import a package,
select Tools > Import and select an xml file.)

Export

Adds the highlighted item to the current project.Add to Project

Select from Source Control options Check Out, Undo Checkout,
Check In, Get Latest

For more information see the section on “Source Control Hooks” .

Source Control

Closes the current document.Close

Closes all documents except the highlighted document.Close All But This

Closes all documents.Close All
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17.12.3 Inspector Context Menu

Right-clicking the Inspector window displays a context menu with the following items (if they are applicable to the current
document in the editor window):

Adds a member selected from the displayed list to the current class
definition.

Add

Opens a window that lists items inherited by the current class, from which
you select. An override definition is inserted into the current class definition
window.

Override

Resets selected item to default.Reset to Default

Deletes the displayed item.Delete

Available when a class member is displayed. Displays the member in the
editor window.

Locate

Toggles the inclusion of inherited members in the window display.Show Inherited Members

Toggles the display of the column headers, Name and Value, in the
Inspector window.

Show Headers

17.12.4 Tab Context Menu

Right-clicking the tabs header displays a context menu with these items:

Closes the current tab.Close

Closes all tabs except the current tab.Close All But This

Closes all tabs.Close All

17.12.5 Window Display Context Menu

Right-clicking a window where no other context menus apply shows the generic window context menu:

Disconnects the selected window from a fixed location; that is, it can be
dragged freely to a desired location.

Floating

Glues the selected window to a default location.Docking

Conceals the selected window.Hide

17.12.6 Debugger Watch Context Menu

To see the Debugger Watch Window Context Menu, see the section Debugger Watch Context Menu in the chapter “Using
the Studio Debugger”  in this book.
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17.13 Keyboard Accelerators
This section lists Studio's keyboard accelerators (keyboard shortcuts)—combinations of keys that, when pressed, perform
a Studio function.

block of text

In the following table, a block of text means a number of whole lines. To select a block of text, put the caret at the
start of the first line, press Shift, and select the down arrow till all of the relevant lines are highlighted. The caret
is then displayed at the start of the line beneath the last whole line.

ActionAccelerator

General

Context HelpF1

Change Namespace or ConnectionF4

Toggles Full Screen Display of Studio menus and editor window.F8

New DocumentCtrl+N

Open DocumentCtrl+O

Open ProjectCtrl+Shift+O

Print

Opens the Print dialog. If text is selected, Selection is checked.

Ctrl+P

SaveCtrl+S

ExportCtrl+Shift+I

Import LocalCtrl+I

Display

Expand All

Expands all sections in the document that can be expanded.

Select minus icon to collapse a section or Ctrl+- to collapse all sections.

Ctrl++

Expand All Block Sections

Expands all sections in this code block that can be expanded.

Select minus icon to collapse a block or Ctrl+- to collapse all blocks.

Ctrl+Left Select plus icon

Collapse All

Collapses all sections that can be collapsed.

Ctrl+-

Show Class BrowserCtrl+W

View Other

Opens documents related to the current document, such as MAC or INT routines.

Ctrl+Shift+V
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ActionAccelerator

Toggles Inspector window displayAlt+1

Toggles Output window display

The Output window has tabs for Result and Find in Files.

Alt+2

Toggles Workspace window displayAlt+3

Toggles Watch window displayAlt+4

Toggles Code Snippets window displayAlt+5

Toggles Find in Files window displayAlt+6

Toggles Class View window displayAlt+7

Increase Font

(Press Ctrl and Alt and the equal sign key — here called the plus sign.)

Ctrl+Alt++

Decrease Font

(Press Ctrl and Alt and the minus key.)

Ctrl+Alt+-

Toggles display of Whitespace Symbols, spaces, newlines, and tabsCtrl+Alt+Space

Toggle Bracket Matching

Turns bracket matching on and off for the current window.

Ctrl+B

Toggles Line Numbers Display.Ctrl+Shift+N

Next WindowCtrl+Tab

Previous WindowCtrl+Shift+Tab

Navigation

Go To Beginning of Line

Subsequent presses hops the caret between the beginning of the line and the
beginning of text on the line.

Home

Go To Beginning of DocumentCtrl+Home

Go To End of LineEnd

Go To End of DocumentCtrl+End

BackCtrl+-

ForwardCtrl+Shift+-

Page UpPage Up

Page DownPage Down

Go To Top of Visible PageCtrl+Page Up

Go To Bottom of Visible PageCtrl+Page Down

Scroll DownCtrl+ 

Scroll UpCtrl+ 
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ActionAccelerator

GotoCtrl+G

Goto Documentation for TagCtrl+Shift+G or F12

Go To Next ErrorCtrl+F3

Go To Previous ErrorCtrl+Shift+F3

Go to Next WarningAlt+F3

Go to Previous WarningAlt+Shift+F3

Go To Bracket

Moves the cursor between the innermost pair of brackets (or parentheses or
braces). Pairs of all three kinds (one of each) can be highlighted if they are
nested.This accelerator works only if bracket matching is turned on (see Ctrl+B).

Ctrl+]

Editing

Toggle Insert/Overwrite Mode

Toggles between Insert mode (new characters are inserted when typing) and
Overwrite mode (new characters replace existing characters when typing).

Insert

Delete Next Word or to End of Word

If caret is at the start of a word, deletes the word. If caret is in the middle of a
word, deletes from the caret to the end of word.

Ctrl+Delete

Delete Previous Word or to Start of Word

If the caret is at the end of a word, deletes the word. If caret is in the middle of
a word, deletes from caret to start of word.

Ctrl+Backspace or
Ctrl+Shift+Delete

Delete LineCtrl+Shift+L

CopyCtrl+C or Ctrl+Insert

CutShift+Delete or Ctrl+X

Cut LineCtrl+L

PasteCtrl+V or Shift+Insert

Select AllCtrl+A

RedoCtrl+Y or Ctrl+Shift+Z

UndoCtrl+Z

Show Popup

If the cursor is in an appropriate location, this displays the Studio Assist popup,
which shows options available for this location (such as classes, methods,
properties, and so on, as appropriate).

Ctrl+Space

Toggle Tab Expansion

Toggles whether tabs or spaces are entered when you press Tab.

Ctrl+~
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ActionAccelerator

Uppercase SelectionCtrl+U

Lowercase SelectionCtrl+Shift+U

Toggles the Delay Parsing option.Ctrl+Alt+O

Titlecase (Initial Caps) SelectionCtrl+Alt+U

Insert Open and Close Parentheses. (Does not work on German and Swiss
keyboards.*)

Ctrl+(

Insert Open and Close Braces.Ctrl+{

Insert Open and Close Square Brackets.Ctrl+[

Inserts Open and Close Angle Brackets.Ctrl+<

Indentation Cleanup. Cleans up indentation on a selected block of whole lines
of text.

Ctrl+=

Comment Line

Turns a selected line into a comment by adding a # (pound sign) to the beginning
of the line.

Ctrl+/

Uncomment Line

Turns a selected comment into a regular line by removing a # (pound sign) from
the beginning of the line.

Ctrl+Shift+/

Comment Block of Text

Pressing Ctrl+/ while a block of text is selected comments the block of text; that
is, adds #; (pound semi-colon) to the start of each line (for ObjectScript routine)
or appropriate marker based on the document’s language. (Does not work on
German and Swiss keyboards.*)

Ctrl+/

Uncomment Block of Text

Pressing Ctrl+Shift+/ while a block of text is selected uncomments the block of
text (that is, removes the #; from the start of each line for Objectscript routine
— or other marker based on the document’s language). (Does not work on
German and Swiss keyboards.*)

Ctrl+Shift+/

Comment Markers Added to Block of Text

Inserts block type comments (such as /*...*/) for specific language if block
comments are supported. If block type comments do not exist, then single line
comment marker is inserted. (Does not work on German and Swiss keyboards.*)

Ctrl+Alt+/

Comment Markers Removed from Block of Text

Removes block type comments (such as /*...*/) for specific language if block
comments are supported. If block type comments do not exist, then single line
comment marker is inserted. (Does not work on German and Swiss keyboards.*)

Ctrl+Shift+Alt+/

In an ObjectScript document, commands in a selection are replaced with their
full names.

Ctrl+E
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ActionAccelerator

Compress Commands

In an ObjectScript document, commands in a selection are replaced with their
abbreviated names.

Ctrl+Shift+E

Insert Dots

With a block of text selected, Insert dots at the start of each line (after leading
white space). Lines must start with leading whitespace. This is for use in block
structuring with leading periods with argumentless DO commands.

Ctrl+.

Remove Dots

Remove leading dots from the start of the selected block of text (for use in block
structuring with leading periods with argumentless DO commands).

Ctrl+Shift+.

Add TaskCtrl+Shift+T

Find and Replace

FindCtrl+F

Find NextF3

Find PreviousShift+F3

Find in FilesCtrl+Shift+F

SearchCtrl+, (comma)

ReplaceCtrl+H

Go ToCtrl+Shift+G

Go BackCtrl+Alt+G

Bookmarks

Toggle Bookmark on Current LineCtrl+F2

Go to Next BookmarkF2

Go to Previous BookmarkShift+F2

Clear All BookmarksCtrl+Shift+F2

Build and Compile

Rebuilds All Documents in ProjectF7

Compile Active DocumentCtrl+F7

Compile with OptionsCtrl+Shift+F7

View as Web PageF5

Debugging

Toggle Studio Debug Logging

Turns logging on or off. If on, information is sent to the file /irisinstall/bin/CD###.log

for Studio debugging purposes. This file can become very large. Use carefully.

Ctrl+Alt+L
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ActionAccelerator

Debug Attach

Attach the debugger to a process.

Ctrl+Shift+A

Debug Toggle Breakpoint on Current LineF9

Debug StartCtrl+F5

Debug RestartCtrl+Shift+F5

Debug Run to Cursor

Resumes program execution and pauses at the cursor line or a breakpoint.

Ctrl+F10

Debug Step Into

From a break or an interrupt, step into the next loop.

F11

Debug Step Out

Step out of the current process.

Shift+F11

Debug Step Over

Skip over the next process.

F10

Debug StopShift+F5

Templates

Open Template

Can be used as accelerators for Studio Templates. To set an accelerator, add
an attribute in the form accelerator="#" to the template (in either the
csp:StudioInteractiveTemplate tag or the csp:StudioSimpleTemplate
tag). This sets an accelerator of Ctrl+Shift+# for the template. The number (#)
can be 0-9.

Ctrl+Shift+1 - Ctrl+Shift+9

Open TemplatesCtrl+T

Wizards: Arguments for New Method wizard and Parameters for New Query wizard

AddAlt+A

RemoveAlt+R

UpAlt+U

DownAlt+D

17.14 Adding to a Studio Menu
To add a menu item to a Studio menu,
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1. In the Studio toolbar, right-click the menu name and select Customize.

2. Select the Tools tab, add the.exe file.
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18
Setting Studio Options

You can modify the behavior of aspects of Studio by selecting Tools > Options.

The Options dialog contains tabs described in the following sections.

18.1 Environment Options
These options control the Studio environment:

General

Preferred Language: Sets the default language version used to create new classes.

Items shown in recently used lists: Specifies the number of items displayed in the most recently used file list (under
the File menu).

Open File Added to Project: If enabled, adding a file to the current project automatically opens the file in Studio.

Tabbed Document Selector: If enabled, displays a tab for each open document. You can choose whether the row
displays on the top or bottom of the Studio window.

When open project show documents from last time: If selected, when you start Studio all documents that were open
the last time you were in the current namespace are reopened. To bypass this option, hold down Shift when Studio
opens.

Hide Find and Replace window after operation complete: If selected, the Find and Replace dialog exits when it
completes it task.

Compare: Select a document to compare this document to using Tools > Compare.

Font

Specifies the typeface and size of the fonts used in the following windows and print: Editor Window, Output Window,
Print, Workspace, Inspector. Each window can use any Windows font but it is limited to a single typeface and
size.

Keyboard

Show commands containing: Specify a command to search for.

Shortcut for selected command: Shows whether the selected command has a shortcut key assigned to it.

Press new shortcut key: Enter a shortcut key to assign to the selected command.
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Shortcut currently used by: Shows whether the shortcut key you entered is currently assigned to another command.

Reset All Resets all keyboard shortcuts to original settings.

Remove Removes an existing shortcut key for the selected command.

Open Dialog

Automatically apply last mask. If checked, the last search mask is used automatically in the File > Open dialog.

Use additional dedicated server process. Recommended only on very large systems if user want option to abort

data collection.  In rare situations on very large systems, searching for a file in the File > Open dialog can take a
significant amount of time. To solve this, check this option to run the search in a separate process. If the search
take more than .2 seconds, Studio displays a progress bar with a Cancel button. If you check this box and an
additional process is started, it affects the license count.

Server defined colors

You can select a color for the status panel background or the document background for a software instance. Display
a color palette by selecting the square to the far right of the instance. Select a color from the palette, which is
shown by a color swatch and its hexadecimal color code.

Documentation and Proxy

HTTP Address used to serve on-line documentation: Specifies the location Studio uses to fetch on-line documentation.
Select Automatic to use the default location associated with the instance, or HTTP Address to supply a different
location.

Templates and add-ins will use Proxy server for ‘IRIS_instance’: Specify the server address and port number of a
Proxy server to load templates and add-ins for the current instance. The Address field supports the address formats
http:// and https://, as well as address such as localhost. If no :// detected in the address, Studio adds
http://.

Class

Multiline Method Arguments: If selected, method arguments are displayed in the class editor one per line. If Multiline
Method Argument is enabled and you use Find in Files, and then select a line in the Find in Files output of a file
that has multiline method arguments, the cursor may go to the wrong line number. Disable Multiline Method
Arguments if this is a problem.

Option explicit: If selected, you see a syntax error if you refer to a variable that hasn't been declared. (Select this
and Studio Assist to display undeclared local variables when entering a #DIM statement in a method or a DO
statement in a routine.)

Show internal class members in Studio Assist: If selected, Studio Assist lists class members marked as internal.

Track variables: If selected, a green wavy underline indicates any questionable use of a variable. For example, this
option highlights a variable is used that has no value, was never created, or has already been killed. It also highlights
a variable that is given a value, but never used or that is killed before being used.

Open class in contracted view: If selected, by default a class opens with all collapsible sections contracted (as
though Ctrl+- had been pressed). If not selected, a class opens with collapsible sections open (as though Ctrl++
had been pressed).

Code Snippets

Display Snippets Check the types of code snippets you want Studio to display. You can define your own sets of
code snippets by specifying a name and a text file. Use Create Code Snippet from the document's context (right-
click) menu. The snippet is created in your currently-active user-defined set or if no set is currently-active, then
in the first set.
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Advanced

Auto Save prevents you from losing changes to Studio documents in the case of a software or system failure. By
default, Auto Save is enabled and saves every 5 minutes. It saves any document that is open and has been modified
since the last save into a file that is a text representation of the document, C:\Documents and

Settings\<username>\Local Settings\Temp\CST*.tmp. If you subsequently save (or close) the document, this .tmp

file is deleted. If Studio crashes, the next time that Studio is opened, you get a message telling you that the temporary
file exists. If you open this temporary document, you can paste the relevant portions into a Studio document.

Enable service status check (Recommended) determines how often Studio checks to see if open documents and/or
the open project changed on the Server outside of this Studio process. If Studio is the active application, it uses
the first setting, Studio is active application (2–60 sec). If Studio is running in the background, it uses the second
setting: Studio is background application (30–600 sec). If you are on a slow system, you can uncheck this option.
As a result Studio will not check server status and will not be able timely detect if documents or project on server
were modified or studio lost connection. Use with caution.

Automatically reload document when it is modified on the server and it has not been edited in Studio: If selected
and you have a document open in an editor, but have not yet edited it, and someone else saves a new version to
the server, the file in your window is automatically updated. This setting can be enabled on a namespace basis
using a global: Set ^%SYS("Studio","Reload")=1 (or 0 to turn off).

Show generated documents in Namespace tree: If selected, the namespace window in workspace shows generated
files. If not selected, generated files are not displayed.

Use INT as default for ObjectScript: If selected, when you select File > New > Objectscript Routine, an INT file is
opened. If not selected, a MAC file is opened.

Pass credentials to View Web Page: If selected, Studio checks your permissions when you select View Web
Page.

Use default language (will cause reset toolbars and restart). If checked, Studio loads language specific resources.
To override your system’s default language (that is, to see all menus in English), uncheck this box. When you
accept the changes, toolbars are reset and Studio is restarted

Export flags: Enter flags that you want to use when exporting files. See the Flags and Qualifiers section of the
$SYSTEM entry in the ObjectScript Reference for more information.

18.2 Editor Options
The editor options allow you to control the behavior of the Studio text editor. These options include:

Syntax Check and Assist

Enable Syntax Checking: If enabled, syntax errors are highlighted. You can specify when syntax checking should
be performed - either on each change (each character that you type or erase) (Syntax Check on Change) or when
the cursor leaves the current line (Syntax Check on Leave Line). You can specify whether you also want the errors
to be underlined with a wavy red line (Underline Errors).

Enable Bracket Matching: If enabled, pairs of matching brackets enclosing the current cursor point are bolded.
Depending on the language you are in, brackets include [ ] square brackets, ( ) parentheses, and < > angle brackets.
Note that for Enable Bracket Matching to work, Enable Syntax Checking must be checked. Bracket Matching Line

Limit Limits the number of lines to search above and below the caret position to locate a matching bracket (as an
unlimited search in a long file would slow the editor down significantly).
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Studio Assist: Enables code completion. As you are entering ObjectScript code, a drop-down menu is displayed
showing available options for what you can enter next. If you type a package name, available classes are listed.
If you type a class, available methods are listed. If you type a method, available arguments are listed. Available
options may be listed in other locations as well, such as with #dim declarations and trigger code.

To display undeclared local variables when entering a #DIM statement, you must be in a method, and you must
have selected Studio Assist and Option Explicit. To be listed, a variable must not begin with %, must not be a
parameter or in the public list, and must not have been declared already.

If you type $$$, available macros are listed as follows: User-defined macros are listed if they are defined in the
current file and if they are defined in an include file and, within the include file, they are preceded by a line
beginning with three slashes, ///. System-defined macros are listed if the current file is a class file.

Following a partial member name, Studio displays a list of matching members as follows: If the partial entry begins
with double-quotes (or a single quote), the popup contains only members whose names must be quoted in the
program; that is, they contain spaces or other non-alphanumeric characters. If the partial entry does NOT begin
with double-quotes, the popup contains only members whose names do not need to be quoted. If Studio Assist is
triggered directly after a period, the popup contains all member names.

Parsing delay. Check if parsing slow. Uncheck if line flashing. If Syntax Check on Change and Parsing delay are
both enabled and you are entering text faster than the parser can reparse, the text flashes between black and the
parsed color. If the text is flashing, disable Parsing Delay by clearing this option or pressing Ctrl+Alt+O. Response
may slow slightly since every keystroke causes a reparse, but the flashing stops. This switch needs to be set at the
start of each Studio session.

Studio Assist provides code completion and assistive popups for RESTSpec XData blocks.

Colors

The Studio syntax checker uses a different coloring scheme for each language it supports. This option lets you
specify the colors used to highlight syntactic elements when Studio syntax coloring is enabled.

To change the color used by the Studio Editor for a specific syntax element, do the following in the Options dialog,
Appearance tab:

1. Select a language (such as ObjectScript) from the available options.

2. Select a syntax element (such as comments).

3. Select the desired foreground (and background color) color.

4. Select Apply to use the new color scheme.

Reset reverts the selected syntax element to its default color.

Reset All reverts all syntax colors to their default values.

Note: You can also change the color for a particular syntax element by right-clicking it in the editor window
and selecting Set Syntax Color.

Keyword Expansion Case

This feature only applies to ObjectScript routines.

Specifies the case (Use Current Case, Uppercase, Lowercase, or Mixed Case) used to expand ObjectScript commands
when you select Edit > Advanced > Expand Commands. Set this option, highlight the code you want to expand,
then select Edit > Advanced > Expand Commands. This also applies if you are compressing commands.
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Indentation

Defines characteristics of automatic indentation.

• Basic: If enabled, if a line begins with a tab, a space, or any combination of spaces and tabs, when you press
Enter, the next line is started automatically with the same combination of spaces and tabs.

• User-defined ('/t' for tab)

If enabled, you can specify any characters that you would like to be automatically entered at the start of each
subsequent line. For example, if you enter the set of characters \t.#/; (tab, dot, pound, slash, semi-colon)
and if a line begins with any of these characters or any combination of these characters, when you press Enter,
the next line is started automatically with the same combination of characters.

• None: No automatic indentation is provided.

Comment

Displays a table of comment delimiters for Studio document types. Select in a cell to enter a delimiter. Highlight
a block of text in a Studio document and press Ctrl + Alt + / to delimit the block with Multi-Start and Multi-End
characters.

View

Controls the display of some items.

• Show Special Characters: If enabled, the editor displays newline and tab characters using special symbols.

• Show Line Numbers: If enabled, the editor displays line numbers.

• Convert tabs to spaces: If enabled, the editor converts tabs to spaces.

• Cloudy background color for generated files: If enabled, the editor displays generated files with a greyed
background color to differentiate them from user-created files.

• Tab Size: Specifies the size of a tab by number of spaces.

18.3 Compiler Options
These options affect how Studio compiles your code. There are two pages, Flags and Optimization and Behavior.

Flags and Optimization

This page includes 3 sections: Compile Flags, Optimization Level, and Flags.

The Compile Flags section includes

Keep Generated Source Code: If enabled, specifies that the compiler should not delete any intermediate source
code (routines) that it creates as a consequence of compiling.

Compile Dependent Classes: If enabled, the compiler compiles all of a class' dependent subclasses.

Skip Related Up-to-date Documents: If enabled, this sets the “Do not compile up-to-date documents”  flag and the
compiler does not compile related documents that have not been modified since their last compilation. The document
that is current in the editor is always, however, recompiled.

Compile In-use Classes: If enabled, the compiler compiles a class even if there currently are instances of the class
in active use.
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In the Optimization Level section, you can set the level of optimization to improve execution speed. If optimization
is enabled, the compiler reorganizes the code for maximum benefit, including the copying of expressions between
classes to eliminate method calls. Levels are:

• No optimization: Recommended during development. It does not recompile dependent classes and it keeps a
strong correspondence between source and object code so it is easier to read and debug.

• Optimize properties: Optimizes any reference to ..property  to the instance variable reference (for simple
properties described by datatypes where the get/set method is not overridden).

• Optimize within class and calls to library classes: Optimizes classes, as well as calls to system (% ) classes (as
code may be extracted and moved during the process). Incremental compile no longer works for optimized
classes.

In the Flags field, enter compiler flags you want used.

To see this list of flags in the terminal, enter: d ##class(%SYSTEM.OBJ).ShowFlags()

To see a list of qualifiers, enter: d ##class(%SYSTEM.OBJ).ShowQualifiers()

EffectFlag

Include application classes. This flag is set by default.a

Include sub classes.b

Compile. Compile the class definition(s) after loading.c

Display. This flag is set by default.d

Delete extent.e

Generate help.h

Validate XML export format against schema on Load.I

Keep source. When this flag is set, source code of generated routines is kept.k

Lock classes while compiling. This flag is set by default.l

Percent. Include classes with names of the form %*.p

Recursive. Compile all the classes that are dependency predecessors.r

Process system messages or application messages.s

Update only. Skip compilation of classes that are already up-to-date.u

Include classes that are related to the current class in the way that they either reference
to or are referenced by the current class in SQL usage.

v

Note: Flags may be turned off by preceding them with a dash (-).

Behavior

• Before Compile: You can choose a default behavior for Studio to take when you select Compile. You can select
that, before compiling, Studio will automatically save all modified documents, prompt to save modified docu-

ments, or do not save modified documents.

• Compile Routine on Save Select this option to have the system compile any modified routines when you select
Save. By default, this option is turned off.
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18.4 SQL Options
Use these options if you primarily use Studio to create classes that map onto existing legacy data.

Legacy Mode: Enable Legacy SQL Mode For Classes

If enabled, the other default settings on this tab are enabled. This option effects only how Studio wizards operate;
it does not affect the runtime behavior of applications.

Default Storage Type: Specifies the storage class used when the New Class wizard creates a new class.

Default $Piece Separator: Specifies the default data delimiter used when defining a mapping to legacy data structures.

Default Collation: Specifies the default index collation used when defining a mapping to legacy data structures.

Private Row ID: Specifies whether new classes should have their SqlRowIdPrivate flag set by default.

Automatically Generate Row ID: Automatically creates a row id field when mapping data to existing storage
structures.

18.5 Studio Look Options
Select a theme from the list to change the color scheme of Studio using this option.
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A
Frequently Asked Questions About Studio

A Question and Answer Set about Studio.

Projects

What is a project?

A project is a collection of class definitions and routines that you can group together for the sake of convenience.

Using projects gives you an easy way to return to your work when you start a Studio session. For example, you can place
all the classes related to an application, or part of an application, in a project. When you start Studio, open this project and
the Project tab of the Workspace window displays all the classes in a convenient list.

You can also export and import entire projects to and from a single external file, making it easy to save or pass around
application code.

How do I add an item to a project?

Here are some of the ways to add items to the current project:

• Before opening one or more items (with File > Open), select the Add to Project check box in the Open dialog.

• To add the item in the current editor window to the current project, select Project > Add Item.

• In the workspace window, highlight an item, right-click, and select Add to Project.

Can I add something from another namespace to my project?

No. A project can only contain items that are visible to the current InterSystems IRIS namespace.

Can an item belong to multiple projects?

Yes. A project is a specified set of items (class definitions and routines) that you choose to group together. The items
themselves have no link back to the projects they may belong to. There is no limit to how many projects an item can belong
to.
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What if I don't want to use projects?

You are not required to use projects with Studio; you can completely ignore them if you like. To ignore projects, do not
add any items to the default project and ignore the prompt asking you if you want to save your project when you exit Studio.

Can I export a project?

Yes. Select Tools > Export > Export Project. Enter a file name and press OK. This exports the entire contents of the current
project (including the project definition) to a single XML file.

How do I delete a project?

Select File > Open to list all your projects. Right-click a project and select Delete.

Note that you can use File > Open to delete any type of item on the server in this way.

Opening Files

How do I open a class definition?

To open an existing class definition (that is, one saved on the InterSystems IRIS server), do the following:

1. Make sure you are connected to the InterSystems IRIS namespace and server containing the class definition.

2. Select File > Open.

3. In the Open dialog, make sure that class definitions are listed by selecting Class Definitions (.CLS) or All in
the File Types combo box.

4. Package names are listed in the file list as folders. Select a package name to list all the classes (or subpackages) within
the package.

5. Double-click a class name to open it.

Alternatively, you can enter the name of the class you want directly into the filename edit box with a .cls extension (such
as Sample.Person.cls) and select Open.

How do I open a routine?

To open an existing routine (that is, one saved in the InterSystems IRIS server), do the following:

1. Make sure you are connected to the InterSystems IRIS namespace and server containing the routine.

2. Select File > Open.

3. In the Open dialog, make sure that routines are listed by selecting either MAC routines (.MAC), INT routines
(.INT), or All in the File Types combo box.

4. Double-click a routine name.

Alternatively, you can enter a routine name with extension directly into the filename edit box (such as MyRoutine.MAC)
and select Open.
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How do I open a CSP file?

You can open a CSP file in the same way that you open a class definition or a routine. The main difference is that the Open

dialog lists CSP Applications (for example, /csp/samples) as folders; select the name of an application to see the CSP pages
within it. Using CSP files with InterSystems IRIS is not recommended.

What does the Show System check box in the Open dialog do?

If the Show System check box is selected, then the File > Open dialog lists system items (items whose names start with the
% character and are stored in the IRISLIB database) along with items in the current namespace.

Can I use pattern matching in the File > Open dialog?

Yes. You can use the “*”  character as a wildcard to match any number of any character as you can in a standard File >

Open dialog. You can use file extensions to filter certain items; for example, “*.cls”  lists all Class Definitions in the selected
package. You can use the “?”  character to match any character. These are Windows pattern matching conventions, not
InterSystems IRIS pattern matching.

How do I open a routine from a different namespace?

The File > Open dialog lists items from the current namespace and server only. To open a routine from a different namespace
or server:

1. Select File > Change Namespace.

2. Open the desired routine.

Can I open a % class?

Yes. You can list % classes (classes whose package name starts with a % character and are stored within the IRISLIB
database) from the File > Open dialog by selecting the Show System check box at the bottom.

Studio opens % classes as read-only if you open them while connected to a namespace other than %SYS.

What does File > Connect do?

Studio maintains a connection to a specific InterSystems IRIS namespace and server. It uses this connection to provide a
list of classes (such as for specifying property types, super classes, etc.). It also uses this connection for debugging. File >

Connect lets you connect to a different server.

Debugging

How do I start the debugger?

You can connect the debugger to a target process in of the following ways:

• Define a “debugging target”  (name of program or routine to debug) for the current project with Project > Settings.
Then select Debug > Go to start the target program and connect to its server process.

• Select Debug > Attach to select from a list of running processes on an InterSystems IRIS server.
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For more details, refer to the chapter “Using the Studio Debugger”  in this book.

How can I debug a class?

The Studio debugger lets you step through the execution of programs running on an InterSystems IRIS server. These programs
can include INT files, MAC files, methods within CLS files, server-side methods invoked from Java, or server-hosted
applications.

1. To view the INT file during debugging and to save the INT for further review later, set the Keep Generated Source

Code option before you compile your class. This option is located on the Tools > Options > Compiler > Flags & Opti-

mization page.

2. Set a breakpoint at the desired location in a class method (or any of the other files mentioned above) by pressing F9

(toggles breakpoint) on the desired source line.

3. Set a debug target to specify where you want the debugger to begin code execution using Debug > Debug Target. Enter
the name of the class and the method that you want to step through.

4. Start the debugger with Ctrl+F5 or Debug > Go.

Can I watch variables?

Yes. While debugging, enter a variable name (or an expression) in the left-hand column of the Studio Watch Window.
Each time the debugger pauses, the variable or expression is reevaluated.

Editing

What do the different colors in the editor mean? Can I change the colors in the editor?

Studio uses colors to differentiate the syntax elements of a given language.

You can change the colors used for the various syntax elements as follows:

1. Select Tools > Options > Editor > Colors.

2. Select a language.

3. Select an element (comment, variable, etc.)—the list of available elements depends on the selected language.

4. Select Foreground and Background colors and select OK.

Why is there a wavy, red line underneath my code?

The wavy, red line indicates that the underlined code (or possibly code before it) contains syntax errors.

Does Studio support Kanji and Chinese characters?

Yes. Studio has complete support for Unicode and Kanji characters.

Does Studio support Hebrew and Arabic characters?

Yes. The Studio Editor supports Hebrew and Arabic characters, as well as bidirectional editing.
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Importing Files

Can I import class definitions or routines from external files?

Yes. Select Tools > Import.

What is the difference between Local and Remote files?

Studio is a client/server application; Studio itself runs on a client system and talks to a server. The server can either be on
the same machine or on a remote machine. Studio uses the terms “Local”  and “Remote”  to refer to operating system files
(such as when you are importing or exporting) that are stored on the client and server systems, respectively.

If both the client and server are on the same system, there is no difference between Local and Remote.

Printing

Can I print from Studio?

Yes. Select File > Print or File > Print Preview.

Templates

What is a Template?

Templates are a mechanism for creating user-defined Studio add-ins. A template is a program that enters a code fragment
into the current document at the current cursor point. You can customize the code fragment to your needs. See the chapter
“Using Studio Templates”  in this book for more information.

Is there a list of available Templates?

Yes. Select Tools > Templates > Templates.

Can I create a new Template?

Yes. See the chapter “Using Studio Templates”  in this book.

Multiuser Support

Does Studio support development by multiple users?

Yes. You can do this in several ways:

• Set up a common InterSystems IRIS server system and have all developers store their code on it.

• Use local InterSystems IRIS servers (on the developer's system) and store source code in a source control system as
exported XML files.
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What happens if I try to open a class (or routine) that someone else is editing?

Studio displays a dialog stating that the class (or routine) is in use by someone else and asks you if you want to open it in
read-only mode.

What if someone wants to edit a super class of a class that I am working on?

Studio does not prevent another developer from modifying the super class of a class you are working on.

While Studio could take out locks on all subclasses whenever a class is opened for editing, in practice this would be
annoying and unwieldy. Instead, a development team needs to work out rules and procedures for defining and modifying
super classes. This is similar to how development teams in other languages (for example, Java) usually work with class
definitions in source control systems.

Classes

How do I create a new class?

Use the File > New and select Class Definition. This invokes the New Class Wizard.

For more details, see the chapter Class Definitions in this book.

Can I see the source code generated for my class?

Yes. You can see all the source code generated by the Class Compiler with View > View Other Code (available when the
current window contains a class definition).

Make sure that the Keep Generated Source Code option is set before you compile your class. This option is located on the
Tools > Options > Compiler > Flags & Optimization page.

When I try to compile my class, Studio says it is up-to-date and does not need to be compiled. Can I force a compile
to happen?

Yes. Turn off the Skip related up-to-date documents option. This option is located on the Tools > Options > Compiler > Flags

& Optimization page.

Routines

How do I create an INT routine?

Create a new ObjectScript routine by selecting File > New and then save the new routine using a name with a .INT extension.
You can create an include (.INC) file in the same fashion.
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SQL

How do I define an SQL View?

Studio does not include a mechanism for defining SQL views. To do this, as well as other SQL tasks, use the Management
Portal.

Source Control

Does Studio integrate with external Source Control systems?

Yes. The procedure is:

1. Create a subclass of the system-supplied class %Studio.SourceControl.Base where you implement the methods to
interact with your source control system. The class that you create is called from Studio in response to particular events
and then performs the actions that you have specified.

2. In the Management Portal, go to the Studio Source Control Settings page (System > Configuration > Additional Settings

> Source Control ), select the site-specific source control class from the list, and select OK.

At this point, Studio has been configured to interact with the source control system. When Studio attempts to open a document,
prior to opening it, the OnBeforeLoad method of your source control class is invoked; typically, this method checks the
timestamp on a file representation of the document and, if it is newer in the file, the method calls an InterSystems IRIS
function to import this into the current namespace. This makes sure that the user is seeing the most up-to-date version of
the file.

If you modify the file and save it, then Studio calls the OnAfterSave method of the source control class, which typically
exports this document to the filesystem. (This keeps these files in sync with the routines, classes, etc. that are in InterSystems
IRIS.)

When you attempt to modify a document, Studio attempts to get a lock on it, which also triggers a call to a source control
method GetStatus. If the file is locked in source control, Studio can then ask if you want to check it out. This triggers a
call to the CheckOut method which performs the actions required to check the item out.

%Studio.SourceControl.Base and %Studio.Extension.Base provide a set of methods that allow you to create interactions
between Studio and your source control system that are as simple or complex as you choose.

Can I create my own hooks?

Yes. You can define hooks—code that is executed whenever items are saved to or loaded from the server. For details, see
Integrating InterSystems IRIS with Source Control Systems.

Compatibility

Can I connect a Studio client to any InterSystems IRIS server?

A Studio client must be running either the same version of InterSystems IRIS or a higher version than the InterSystems
IRIS server that it is connecting to.
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Can I run Studio on Linux?

The Studio client only runs on Windows platforms. You can use a Windows-client to talk to any server. You can also use
a partition manager, such as VMWARE, to run both Windows and Linux partitions on your development system and run
Studio in the Windows partition with InterSystems IRIS running in the Linux partition. The only trick is to configure your
networking so that the Windows partition can talk to the Linux partition via TCP/IP. Studio can also run under Windows
on an Intel-based Macintosh.

Studio Implementation

Why doesn't Studio use the licensed components of Microsoft Visual Studio?

There are several reasons why Studio was built from the “ground up”  instead of licensing or extending Visual Studio:

• The Studio editor uses advanced parsing technology not available within the Microsoft Studio framework.

• Microsoft cannot guarantee the compatibility of future versions of Visual Studio.

Why wasn't the Studio interface developed using Java?

At this time, the only way to get acceptable performance for the Studio editor is to use direct calls to the Windows API.
While there are syntax-coloring editors developed using Java, they do not offer the sophisticated multi-language parsing
used by Studio and they typically require very high performance computers for decent performance.
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